ES9023 Dac doesn't work on Rpi2 with Osmc

hi
i’m using es9023 dac on rpi2 with osmc
I’ve made settings like below :

sudo apt-get install alsa-utils

sudo nano /etc/modules

Adding the content below, store them by “Ctrt+X” and then withdrawl

snd_soc_bcm2708
snd_soc_bcm2708_i2s
bcm2708_dmaengine
snd_soc_pcm5102a
snd_soc_hifiberry_dac

sync
sudo reboot

In Settings > System > Audio Output I can select** ALSA: Default(snd_rpi_gifiberry_dac Analog)** but at this moment system is hangs.

who can help me .thanks.

Hi,

Same problem Here.

I have a U Sabre v3 from Audiophonics (http://www.audiophonics.fr/fr/dac-diy/audiophonics-i-sabre-dac-es9023-v3-tcxo-raspberry-pi-20-a-b-i2s-p-10657.html) which is based on the very same chip and a raspberry 2.

I have the exact same symptoms as you: I can select it in the menu but no sound comes out.

I’m investigating this problem right now and will post a reply if I find the solution.

I can tell though that it previously worked with Openelec, which is very close to be the same OS. So all hope is not lost.

Regards,

David

Dear all,

I spent some time on the Raspberry configuration and still no sound, though the DAC seems to be recognized.

As a reminder : I have a Raspberry Pi 2 B rev. 1.1, the Raspberry touchscreen and a DAC from Audiophonics based on ES9023.

Here is my current configuration:

/boot/config.txt

gpu_mem_1024=256  
hdmi_ignore_cec_init=1  
disable_overscan=1
start_x=1  
disable_splash=1
dtoverlay=hifiberry-dac-overlay  
#dtoverlay=lirc-rpi:gpio_out_pin=17,gpio_in_pin=18
gpu_mem_256=112  
sdtv_aspect=1  
gpu_mem_512=144  
dtparam=audio=off  

/etc/modules : empty

/etc/asound.conf

pcm.!default {
  type hw card 0
}
ctl.!default {
  type hw card 0
}

when running aplay -l, I get :

**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: sndrpihifiberry [snd_rpi_hifiberry_dac], périphérique 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
  Sous-périphériques: 0/1
  Sous-périphérique #0: subdevice #0

dmesg doesn’t seem too afraid:

[    4.632306] snd-hifiberry-dac sound: ASoC: CPU DAI (null) not registered
[    4.632332] snd-hifiberry-dac sound: snd_soc_register_card() failed: -517
[    4.638383] snd-hifiberry-dac sound: pcm5102a-hifi <-> 3f203000.i2s mapping ok

So, what I understand is that :
1- the DAC is recognize and setup by the system - hence the aplay output
2- I can select the ALSA default in OSMC settings, thus enabing the usage of said DAC
3- for some reason, I still have no sound coming out of the DAC.

Any idea?

Thanks !

David

Hi

Are you using omxplayer or mmal acceleration ?
AFAIK, only mmal is the supported when using ALSA…

(I had to disable omxplayer to use my Digi+)

Hi and thanks for the reply.

Actually, I did not try to watch any videos. I was just listening to music.

Oh, well, I tried to reinstall Openelec and it was not working either. Guess there’s simply something wrong with the device.

I return it to the seller and try something else. I read that Pi-DAC+ is good.

I’ll ask this forum in a different thread if it’s good or not.

Thanks for your help!

Cheers,