Estuary skin problem

Actually I’m running Kodi 20.1 with OSMC default skin. When I try to change to Estuary skin I’m getting error / message that there were problems with it. Previously I performed “Reset Kodi on next reboot”

Log is here:

Could you pls investigate the problem and advice how to troubleshoot it??

Many thanks in advance

Are you referring to the ‘can’t build menu’ error message? If so that is a known issue without a known solution. It doesn’t actually affect anything so it can safely be ignored. It only shows up if you have the “skin shortcuts” add-on installed and enabled. You can disable it but this limits skin customization for skins that use it.

Yes, it is…to be more specific, it says “Unable to build menu” message. I ignored it but the main menu is very wide, off the screen.

Could you pls advise how to disable this Skin Shortcut? I seem I cannot find it out.

Many thanks

It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off

Either you or some weird script has done something very strange to the Estuary folder. Estuary doesn’t use Skin Shortcuts (or any other addon), but I see in the log that you have a file from Skin Shortcuts in:


There are also a bunch of errors about not being able to open a file when you try and use the OSMC skin, like this:

/usr/share/kodi/addons/skin.osmc/xml/Coordinates_Includes_Home.xml: Failed to open file

So I think you have a more significant issue to resolve than just disabling an addon.

1 Like

settings>system>add-ons>manage dependencies>skin shortcuts>disable

It works now, menu now fits the screen.

It was previously set to Just scan - Auto and by setting it to ON worked out.

Many thanks!

Thank you for navigation.

I tried to disable it but got message that other skins use it (Arctict Zephyr namely) and it cant be disabled.
Nevermind for now skin works just ok.

I have seen it too…log is flooded by error messages. We will see what comes next, if other problems surface out by using it.

Thanks everybody for great support.