Eth0 stopped working after update

Hey Sam! As promised, here are the logs. Two days ago I ran updates. After restart, eth0 failed DHCP. Doesn’t work with static IP either. Got it working with WiFi for now but really hoping there’s a fix that doesn’t involve reinstalling.


Same problem here. No eth0 connection. WiFi is working. I’ll try to get logs tomorrow.

I can think of a couple of changes that could cause this issue.
Can you reproduce this with a cold boot?

@prisoner881 As an aside, you shouldn’t have your GUI set to 4K.

I’ll build a fix and make it available for testing shortly.

1 Like

Cold boot is no different.

As for the GUI, had it at 1080p60 but something weird started happening with the edges getting cut off a couple months back. Switching to 4K was the quick fix.

You should disable overscan instead.

Switching to 4K will give you performance and playback problems.

Interesting. I don’t recall enabling overscan…unless you’re saying it’s on by default. I’ll look for it and disable. Is overscan under video settings?

Regarding performance/playback issues, none to report although the GUI is obviously faster at 1080p.

Out of curiosity, is the eth0 problem an artifact of me being on the beta track previously?

Overscan is a setting on your TV.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off
1 Like

Shouldn’t be the case, but you still have the experimental repository active in your logs, so you can expect regular breakage.

Hi @prisoner881

As you have the staging repository activated, can you try updating again and seeing if Ethernet now performs as expected?

If not – please post some logs via grab-logs -A.

You might want to disable WiFi via My OSMC → Networking to ensure that Ethernet is indeed active.




Ran updates and eth0 is working again. Also took your advice and disabled overscan on my Samsung TV, going back to 1080p60 with no issues.

What was the issue with eth0? Seemed like something you were able to track down quickly and the IT guy in me is curious :slight_smile: .

Hi @prisoner881

We’re not done yet :slight_smile:

The fix I made should restore Ethernet behaviour to how it was before the November update, but isn’t ideal going forward.

It’s possible the previous kernel didn’t install properly and this caused your Ethernet issue.

Can you confirm if:

sudo apt-get install --reinstall vero364-image-osmc-4.9.113-56-osmc:arm64 and rebooting results in non-functional Ethernet? Can you paste the full output of this command here.



@prisoner881 Scrap that. Can you try updating via My OSMC again and confirm if your Ethernet connection stays up?

Many thanks


Ran updates. Took a very long time to download for some reason, download speed of about 10kb/s despite my Internet being gigabit.

Anyway, after about 30 mins of downloading, it prompted for reboot to apply. Eth0 stayed up after the reboot.

Thanks for confirming that Ethernet now works as expected.

1 Like

Thank YOU for jumping on this so quickly and solving it. I’ve had my Vero 4K+ for a few years now and your support has always been outstanding. Makes it very easy to recommend you to others!

1 Like

You’re welcome. Any issues, let us know.