Ethernet (DHCP) not working after July update

Just updated my Vero4k and my wired network connection is no longer working it was being automatically configured by DHCP, it says there is no wired connection now though. Wireless is still working but not ideal. Has anyone else faced any issues with this?

Could you ssh into your Vero and paste the output of ifconfig here?

osmc@osmc:~$ ifconfig
eth0: flags=-28669<UP,BROADCAST,MULTICAST,DYNAMIC> mtu 1500
ether c4:4e:ac:0a:af:3b txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1933 bytes 8362 (8.1 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 40

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 4096
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 0 (Local Loopback)
RX packets 1168 bytes 94176 (91.9 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1168 bytes 94176 (91.9 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC> mtu 1500
inet netmask broadcast
ether 44:2c:05:9d:60:52 txqueuelen 1000 (Ethernet)
RX packets 208 bytes 21391 (20.8 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 276 bytes 45557 (44.4 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


sudo ifdown eth0
sudo ifup eth0

ifdown is not found, I ran sudo ifconfig eth0 down and then up, still no wired connection.

I’ve split this in to a new thread

Try connmanctl enable ethernet and cold boot the device.
If no joy, then some logs might help.


Error ethernet: Already enabled
osmc@osmc:~$ connmanctl disable ethernet
Disabled ethernet
osmc@osmc:~$ connmanctl enable ethernet
Enabled ethernet
rebooted, still no dice.
after trying to enable to adapter in the GUI a couple times I get a pop up saying the network plug in had an error, but I am no longer able to grab-logs after I see that.


Try disabling wifi. Shutdown, then power back on.

Thanks Tom.

Didn’t work, I didn’t have wifi on to begin with when the problem happened, I only turned it on so I could access through ssh


If you can connect a keyboard to vero4k. Exit kodi and press escape to get the terminal.


conmanctl disable wifi
conmanctl disable ethernet
conmanctl enable ethernet.

Thanks Tom.

Didn’t work either, Also now I am getting a popup saying
osmc update error
error installing
please report this to the osmc forums
but all I can do is click ok.


Please provide a fresh log, so we can try work out what it tried to install?

Thanks Tom.


Doesn’t look like its tried to update any packages since you updated to the july release, and looks like all the packages are are to date, you could double check from the command line:

sudo apt-get update
sudo apt-get dist-upgrade.

Not that it should make any difference at this point, but just out of interest have you got wait for network enabled in MyOSMC?

Thanks Tom.

all is latest,

I didn’t but I turned it on, same result.


Could you please issue the following commands and provide the links provided:

cat /sys/class/thermal/thermal_zone0/temp | paste-log

top -n 1 -b | paste-log

Also it may good for a comparison of top with the wifi disabled, so will need a keyboard and do this in 2 stages so you can upload the log once your back online:

top -n 1 -b > ~/top-output

cat ~/top-output | paste-log

Also is the powersupply connected straight in to the power socket or an extension lead?

Thanks Tom.

No RX packets, did you try another cable or router port?

I haven’t tried a new port but I have now reinstalled OSMC a couple times and still no dice, I’m starting to think it is on the router side, something to do with my DHCP. Is there a way to force OSMC to drop it’s DHCP lease and acquire a new one?

Well, if you reinstalled than OSMC wouldn’t have any clue about it’s latest DHCP lease.
I think as a first step I would try to use fix IP to see if that fixes the problem.