Everything but HDR working w/LG B7 OLED TV

Received my Vero 4k+ this week.

The bad:
Included HDMI cable didn’t work
Included remote didn’t work (plugged in another one I had from HTPC which worked fine)

The good:

Reading through the forms and connecting some other dots I was able to make a lot of progress in getting everything playing today. Updated to the latest version after I originally configured it which seems to have removed a couple of the options that have been previously mentioned in other threads such as HDR autoswitching.

Important Note for anyone with a LG B7 or similar: In order to get 4:4:4 support you have to set the input type to “PC” on the HDMI port which is completely not obvious.

Doing this actually fixed two problems I was having: 4:4:4 playback AND 10 bit playback. Once I did this I was able to play 10bit video with 4:2:0, 4:2:2, and 4:4:4 (no more blank screen).

Prior to this I was able to get 8bit playback with 4:2:0 and 4:2:2 but not 10 bit as tested and confirmed by
echo 8bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr AND
echo 10bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr then looking at the conf file while video was running.

So as of now everything seems to work EXCEPT I don’t get HDR (tested w/Sony Swordsmith HDR as well as couple of movies that have it) and am looking for guidance and/or suggestions about where to go from here.


Have you tested it with another device?

Please explain this in more detail.
Did you connect the supplied dongle?

Have you tried re-pairing the remote?

Please post a log. Do you have Adjust Refresh Rate enabled? This is a pre-requisite for HDR to work properly.


To re-pair:

  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.

Hi there,

Wow that was fast, thanks…

Didn’t test the cable with another device, and I just followed the directions in the manual with respects to the remote (tried switching usb ports, tried multiple times, etc.) I didn’t see any info about repairing and frankly I have a remote with a full keyboard/touchpad that I prefer anyways so no biggie.

Yes Adjust Refresh Rate is enabled and I captured logs:

The remote should work (make sure you removed the battery tab) and see a blue light when you press a key.

Set the GUI to 1080p and try again.

The blue light on the remote would come on and stay on solid.

If I am understanding you correctly it was already set and I just verified it is set to 1080p:

Settings->System->Display->Resolution is set to 1920x1080p.

This means the dongle is not connected is not paired (see above)

I’m guessing your Marantz doesn’t understand HDR. Does it work if you plug Vero direct to the TV?

Marantz HDR compatibility here: https://marantz-uk.custhelp.com/app/answers/detail/a_id/4725/~/hdr-format-compatibility
(I had it bookmarked from when I was researching a new receiver a while back).

Thanks. We don’t know the model of @blkadder’s AVR, only that it’s 4 years old so HDR support seems unlikely.

Edit: It is possible we will be able to force HDR through a non-HDR AVR so don’t rush out and buy a splitter just yet. A quick test on my old Yamaha gets my TV reporting HDR but it’s not passing through 10-bits and it doesn’t work with HLG. Stay tuned.

@pullam Thanks for the list! It seems that is it as the Marantz is a plain 7702 which doesn’t seem to support HDR.

Appreciate all the help and super-fast response @sam_nazarko and grahamh.