ExFAT external HD not Mounting on RPi2


I’m trying to mount a powered external USB drive to a Raspberry Pi 2. I already did set max_usb_current=1.

Here is the output from fdisk -l:

Device Boot Start End Sectors Size Id Type
/dev/mmcblk0p1 2048 499711 497664 243M c W95 FAT32 (LBA)
/dev/mmcblk0p2 501760 31115263 30613504 14.6G 83 Linux

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x7bc34569

Device Boot Start End Sectors Size Id Type
/dev/sda1 2 1953525167 1953525166 931.5G 7 HPFS/NTFS/exFAT

I tried editing fstab, to no avail.
blkid produces the following output:

osmc@HanSolo:~$ blkid
/dev/mmcblk0p1: UUID=“CFA4-7A16” TYPE=“vfat” PARTUUID=“935cf2ac-01”
/dev/mmcblk0p2: UUID=“85f204c0-0d30-485f-adee-e6b37ca9bbc7” TYPE=“ext4” PARTUUID=“935cf2ac-02”
_/dev/mmcblk0: PTUUID=“935cf2ac” PTTYPE=“dos”

The output from lsusb is as follows:

osmc@HanSolo:~$ lsusb
Bus 001 Device 004: ID 174c:55aa ASMedia Technology Inc. ASMedia 2105 SATA bridge
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I think the drive should be the ASMedia Technology Inc. thingy, but cannot understand why it’s not mounted or even recognized.

The system is up to date, the grab-logs output can be found here:


I tried various helps and logs around, but cannot find a working solution. Can someone point me towards a solution?

Nov 05 00:29:57 HanSolo kernel: Buffer I/O error on dev sda1, logical block 976762498, async page read
Nov 05 00:29:57 HanSolo kernel: Buffer I/O error on dev sda1, logical block 976762499, async page read

Looks like a problem with the drive. Maybe connect it to a WIndows system and do a chkdsk, and then safely remove it.

This can also happen when the disk doesn’t get enough power.

@bmillham, thank you the drive is now being chkdsk’ed by a Windows 7 machine. I will report more when it’s done.

@sam_nazarko: thank you for the tip, I was aware of the issue, so the USB drive has an external power supply running it. The output I posted above was collected with the drive connected to its power supply (and the Pi, of course).

quick update: I am transferring the data from the USB disk to another one, as the thing stopped mounting on my OSX system. Once the data is safe, I will re-format the drive, and test then.
Thank you for your suggestion

I’d do some real good stress testing before putting any critical data on the drive again :wink:

After getting data out, I formatted (NTFS) the disk again. I am testing now. Seems to work, gets mounted under “media” automatically. Thank you for the tips, much appreciated. I’d consider the issue closed.