Extern USB-Drive as Network Drive

Hi there my Name is Rolf and iam from Germany.

I got a WDTV Live, but since i bought shortly a 4 K TV (Samsung Q55Q80) , i need a new Player because the WDTV dont support x265 or even 4k.

So i bought a Vero4k+ and now i tried to find out how Kodi works.

I read a lot , and some things work great, but one thing i dont get to work.

I got a 3 TB USB Harddrive connected direktly via USB on the Vero4k, same Configuration as i got before on the WDTV live.

Whit the WDTV, there was no Problem to see the USB-Drive in TotalCommander as Networkdrive, so i can connect my PC with the USB-Drive and move Files from PC to the Drive with the Total Commander without any Problems. I could open 2 Mirrors in the Total Commander and move Files directly on the HardDrive without buffering on the PC.

Now i dont be able to see the Drive as Networkdrive. it dont shows up. I can connect via FTP,but i want to involve the Drive as Networkdrive in my Network, so in can involve them als Networkdrive in Total Commander whit a Driveletter - so i got it with the WDTV.

In Kodi i enabled FTP, SSH and Samba. FTP-Server, SSH-Server and Samba-Server are running.

In WORKGROUP i see a Samba 4.5.16- Debian Device. this is the Vero4k but only the interal Storage of the Vero - OSMC Home Directory, not the external USB-Drive. there is no directory to link to the USB-Drive.

Must i enable something in Kodi to give the Drive free ?

Can someone give me an Advice what to do, to see the external USB-Drive as Networkdrive. It was possible with the WDTV and this Device was 8 Year old. i cant believe this dont work with a modern Device like the Vero4k.

Excuse my lousy english.

Thanks and have a nice Day


Try installing samba server in the MyOSMC store.

Thanks Tom.

So I assume you installed the Samba Server from the App Store or did you manually install it?
The one from the App Store would automatically share any USB automounted drives.

If you have installed the App Store version and you can not see the USB drive share logs via grab-logs -A or the MyOSMC Log Uploader.

It’s the AppStore Version. I try the MyOSMC Log Updater tomorrow and give you an Update

This probably isn’t related to your problem, but just as a general tip: if the hard drive powers itself from the USB port, the Vero 4K probably won’t produce enough electric current to drive it. If the hard drive has its own connection to the electricity supply via a wall socket, then everything will be fine; but if not, then it will work better connected to a powered USB hub.


Okay thank you.
I really connected a 2.5 Zoll Device directly on the Vero.
I switch now to a self-Powered 3.5 Zoll Device.

THANK YOU very much. it works :grinning: I think the MyOSMC Log Uploader solve the Problem.

unfortunately another Problem shows up. :pleading_face:

I downloaded some Samsung 4K HDR Demo to watch. If i put a USB-Stick directly in the TV the File - UHD with HDR 10+ - runs very smooth.
If i play it with the Vero it runs jerky and have some stutters - micro stutters, and the Sound stocks sometimes.

Have someone the same Behavior with 4K HDR Files ?

Is it maybe a Skin Problem ? I use at the Moment the Aeon MQ8 - the Skin allows to make own Categories in the Main Menu :blush:

Or should i have to make some Configurations in the Vero ?

Thank you for your Help und have a nice Day.


For HDR10+ you would need the new 4.9 Kernel that is currently in testing.
But the Video still should play without jutter even on the current Kernel.
Would need to see debug enabled logs to give further advice.

Thanks. How can i get the logs you need ? (Sorry , im not realy familiar with Kodi).

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thank you. Log is Uploaded to: URL: https://paste.osmc.tv/izavusinuv

Try your demo file again after adjusting your setup…

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Ok, so your harddisk seems to correctly automount to /media/Mediaplayer means lets look into more details for the samba config.
Can you login via SSH and provide URL of
paste-log /etc/samba/smb.conf
paste-log /etc/samba/smb-local.conf
paste-log /etc/samba/smb-shares.conf

Also install smbclient sudo apt-get install smbclient and run smbclient -L localhost and post the output.

Thank you very very much. The Problem seems to be solved by using the recommend settings that @darwindesign postet.

In Settings>System>Display>is the Option USE LIMITED COLOR RANGE 16-235 enabled.

Ive got a Samsung Qled Q80 TV who is able to show HDR10+. Should i let the Limited Color Option enabled ?

And - i hope you dont mind another question - can you give me an advice for a useful Skin.

I used a WDTV befor and sorted my Videos at the Harddrive in 14 Kategories. I search for an easy use skin who allowed me to shows this Kategories directly at the Mainmenu. With Aeon MQ8 it works, but this Skin has way to much options for a Kodi-Starter.

Thank you all very much and have a nice Day.


Yes, leave that enabled.

If you use the OSMC skin, you could do something like this with a smart playlist. If you want to pursue this, go ahead and open a new topic and I’m sure people will have ideas for you.

To add to what bmillham said the limited color range does not affect HDR content. You can find a lot of info on this subject and most others on Kodi’s wiki.

As for the skin I would recommend just looking around and figure out how to tweak whatever you find suits your preference. Even with very limited skins such as Kodi’s default Estuary which doesn’t allow you to add main menu items, still allows you to add categories to the home screen widgets, so once you find what you like, there will probably be a way to get the function your after.

I somehow was still looking at your original samba problem but that seems to already had mystically solved it self.

Oh iam sorry.

I wrote yesterday : THANK YOU very much. it works :grinning: I think the MyOSMC Log Uploader solve the Problem.

I meant the Harddrive-Problem. Harddrive shows up now in Total Commander and i can involve it as a Networkdrive.

Sorry for beeing unclear und much Thanks for your help and your Time.

Have a nice day


Ok, while I doubt it was the Log Uploader.

I guess it was this

1 Like

I think your right. To be honest - as i write the post - i had no idea what exactly the function of the log uploader is.