External drive ext4


#1

Is having an external drive formatted as ext4 better and faster than NTFS Or whatever format they come in as default I think its NTFS. I just formatted a two terabyte hard drive to ext4 set the permissions it automounts works perfectly I was just curious about performance if there is a difference?


#2

Yes, ext4 is a native Linux filesystem that is directly supported within the Kernel (closes to the hardware layer) while NTFS will use userland parts to get mounted. So performance will be higher with ext4 and also CPU usage will be lower.


#3

And I just realized it will display proper information thank you for the answer. This screenshot is on a drive that is NTFS https://www.backtrails.net/next/index.php/s/tAdENsAWNMtwJge And this one is ext4 https://www.backtrails.net/next/index.php/s/eG3Q8Mc94dExWFe It is interesting how it will display more information. Perhaps I have a project coming up transferring media and a lot of it not looking forward to that but thankfully every time an external hard drive is on sale I end up buying one lol I have 5 in all I guess I’m always afraid of losing data lol


#4

So now that I’ve added content to it sometimes I like to add content that I get off the web that sometimes locks up the Vero 4k+ (Bad encoding of the video) when this happens regardless if the content it’s on the external drive with ext4 or my other external drive that’s NTFS once I reboot which unfortunately is a hard reboot being that it is locked up the Vero 4k+ it fails to recognize the external drive that is ext4 which requires mean to fsck -y on that drive to fix the issue I’m starting to question is it worth it to have your external drives ext4 even if you are a full-time Linux user like me for your regular machines and want to stay true to a format that is more native to Linux. There is one more thought the external drive that I formatted to ext4 is one of the first two terabyte hard drives I bought it maybe 2 to 3 years old and it’s been formatted a couple times playing around with OpenMediaVault on a Raspberry Pi however I ran that drive on OpenMediaVault for probably 8 months it would spend down when not in use all I would use it for was backing up important files but I stopped using OpenMediaVault on the Raspberry Pi 3+ I’m going to build a proper NAS server here pretty soon. And to be honest I was running low on my 4 terabyte hard drive for Vero well not super low 500 gigs left. My question to you guys/gals what are your thoughts should I go back to NTFS on that drive. I know once I build a proper NAS I will just stream the content.


#5

A new issue has raised I would like to pick your brain on what your opinion would be I wrote it all down below. Actually above is that this is a reply lol just noticed that after posting :joy:


#6

I’d recommend using exFAT if you want to move it between a Windows machine.
ext4 is the best option if you’re doing Linux only.

Sam


#7

Thanks for the reply Sam all my computers are Linux except for one that only gets used for recording music and it’s off most of the time.


#10

Since you use linux, I’d assume that instead of simply power-cycling the 4K that you’d SSH in and either restart Kodi or do a graceful reboot.

But it’s odd that you need to fsck so often, I do occasionally need to force a reboot with a power-cycle and rarely do I need to fsck (I use either ext4 or btrfs on my external drives)


#11

Tried that it locked it up good I’ve had to do it twice but since then it seems to be working good. My first instinct is always to ssh in lol. btrfs Interesting what made you choose btrfs I understand it has a lot of extra features, correct me if I’m wrong but didn’t openSUSE use btrfs as default.


#12

I like the features that btrfs offers, but I have found support on other devices to be poor. I had a drive corrupted that was connected to my WD MyCloud that was btrfs, so nowdays I use btrfs for internal drives and ext4 for external.

I think you are correct that openSUSE used btrfs.

Can you supply an example of a video file that causes this behavior? Having a video cause a complete hard lockup is very strange.


#13

I have deleted the MP4s that caused the two different occasions but I would much rather not look for them again see my friend they were adult features clips from some random website on one of those lonely nights ok two lonely nights lol all the other material that I have has never locked up the Vero. I have had lockups in the past and I can get into ssh and lockups we’re eventually it just corrects itself before I even make it to the computer to ssh but that was on the Raspberry Pi 3 and then eventually the Raspberry Pi 3+, however, knock on wood other than the total lockups that I had with the adult features all has been good I was dreading you asking for the videos lol to see if you could replicate the error for a possible fix lol and here we are. If I ever run across this error again with suitable material I’d be more than happy to pass it along. And by the way, I have noticed a slight difference in CPU usage with my ext4 external compared to the NTFS external and it could be just in my mind but response time on fast-forwarding and rewinding seems to be quicker in the ext4. Not to change the subject or go off hand but since we’re talking about different formats. I have an old laptop 500 gigs hard drive and got a cheap USB enclosure for it. I’ve tried and tried to get it to work it has some bad sectors on it will work in a Windows machine all day long however when you plug it in to any osmc eventually it stops reading it after a certain period of time I’ve tried NTFS and ext4 I wonder what would happen if I formatted it to btrfs or a different format I heard Sam mention exFAT earlier. I just want to see if I can get the thing to work if not I don’t mind turning it into refrigerator magnets like I said it’s an old hard drive that I took out of my girlfriends old PC to replace it with an SSD. I’m just obsessed with the thing because I feel there’s something I’m doing wrong.


#15

It’s possible the way you obtained these clips or their encoding wasn’t quite up to scratch.

Let us know if you run in to any problems.


#16

Thats to be expected as ext4 is handled in the kernel and ntfs is handled in userland.

It’s time to retire the drive. You could try btrfs but it can’t help with a physical drive failure. I personally would not use a drive that I know has bad sectors.

There is no way we can try and replicate and fix the problem without an example. Looks like the source of your videos is just doing a really bad job of encoding.