External drive won't spin down when not active

Hi,

I have connected my Buffalo usb drive to the Vero but the drive will not spin down when not in use. The drive worked fine on the PI is there any setting I can change to get the drive to spin down when not active?

Regards

1 Like

Hi Matthew, I’m currently running a similar experiment with my usb HDD, which does seem to go quiet when not in use.

I’d be interested in anyone who can provide a ‘real’ answer, but maybe as a short term work around you could connect the drive to your Pi and network share it with your Vero? Course it mean having you Pi powered on too…

I have installed “hd-idle”…

http://hd-idle.sourceforge.net/
1 Like

There is a bug in hdparm. I am willing to push a proposed fix if you would be willing to report back on this

This is currently affecting all builds, including Pi

Sam

I will gladly report back on anything. I am using OSMC on an RP1 and it refuses to spin down my external drive. What can I do to help ?

Any more news on this issue?

Hi Sam,

Yes I will give it a test.

Let me know how to install it.

Regards

Matt

I’d be happy to test the fix too, I’m using a seagate backup plus slim which does not spin down even when the Vero is idle for days.
Also I’m not sure if it’s related but the hard drive seems to stay spinning even when the Vero is shut down.

That is expected behaviour – if OSMC wasn’t responsible for spinning up the disk, it will not spin it down.

It seems hdparm is somewhat limited, so we’re going to change how we handle disk spindown, although it seems not all disks / caddys support spindown, but we will do our best

S

Thanks Sam. I’m pretty sure the hdd spins down when it has been idle while plugged into my laptop.
In regards to the drive not spinning down when Vero is shut down, I’m not very technical so I have no idea what is responsible for such things, bear with me :stuck_out_tongue:

Seeing similar problem with my new WD Elements USD drive. I’m sure it should be spinning down after a period of inactivity. Fingers-crossed a solution can be found :wink:

Has any solution been found yet? I love my Vero just want the spin down to work too :heart_eyes:

Allo, i’m very interested in this issue - my WD 3.5" drive in a Vantec NexStar 6G enclosure insists on spinning constantly. I’ve just tried out OSMC as an XMAS project and it’s awesome! I just really want to be able to access a copy of my files without our main computer turned on (trying to be energy efficient :smiley:)

I walked through HDPARM and HD_idle suggestions and just managed to make the HDD activity light flash sequence change. Now working with a fresh OSMC install and issue persists.

If i power down OSMC the hard drive activity stops.

Many skins (including OSMC skin) use skin widgets add-on to search for newly added content to populate the “Recently Added” functions of the skin. To avoid waking the HDD, use a skin that does not provide recently added function or disable the skin widget.

I’ll give it a shot

  • it also looks like WD drives with ‘Green’ features’ have known issues and WD have some fixes via WDIDLE3 OR WD5741

to wrap up - i’m off to buy a different HDD,

  • disabled ‘intellipark’ using WDIDLE3 on my WD Green drive
  • drive does not support the -B feature of HDPARM
  • set sleep time to 1 using HDPARM.
    Net result was a clunk sound every few seconds from the drive - maybe sleeping? but somethings waking it up. Same effect plugged into an clean Ubuntu install but no problem in windows.

so after giving up I reformatted the drive as NTFS but also tried the Widget suggestion - and the problem is now gone…
After pushing it back to EXT4 - the issue came back… so it’s the file system?

Probably how UDisks acts on the filesystem.

I spoke to @DBMandrake about moving to a new diskmounting system, but UDevil didn’t do what we want, and @DBMandrake is very busy lately, so we’ve hit a roadblock here.

Sam

1 Like