External Gigabit Adapter on Vero 4k+?


#1

EDIT: So far even though my internal Ethernet port tests well, content from either NAS remains unplayable. Switching to an external USB Ethernet adapter solved all the issues. So if your having the same issue you can easily fix it for about $10.

I received my Vero 4k+ yesterday and seem to have the dreaded slow Ethernet problem. I have content on two NAS systems a synology and a Qnap. The synology is on a 10gb connection and Qnap on 1gb. Doesn’t matter my vero wont stream 4k content over the network. Amazon is delivering a usb to Ethernet adapter today and I am hoping it solves the issue since I am in the states and shipping back and forth is something I am trying to avoid.

My question is, has anyone tried this. I see a lot of issues on here with the built in controller and I was hoping beyond hope I would avoid the issue. Anyway while I wait for amazon to deliver hoping that someone else has tried this with good results :slight_smile:

Coming from an nvidia shield and before that a htpc. High hopes for the Vero as being able to change colorspace and framerate on the fly just sounds epic.


#2

What’s the order number? We haven’t been shipping any problematic devices for well over a month now. We are testing all of the devices before dispatch.

Can you make sure it’s on the latest software?

We had a few units affected, so it’s not unreasonable to expect a device with working Ethernet. In the end we replaced about 22 units.


#3

Order# 20921

I ordered it last week, I worked on it for about 4 hours yesterday before just plugging my shield back in and took the kids out trick or treating :slight_smile: But I am on the October update.

I still have to wrap my head around iperf but hoping the external GB adapter works then problem solved, I’ll know in a few hours. I first noticed the speed issues when it was initially scraping local content it was taking like a minute or more per movie, wheras the shield and pc install can local scrape the whole library in around 5 min. Then If I try to play a mid sized rip it works ok, but remuxes and uhd remuxes (which is almost my whole setup) almost instantly buffer and I get the message that the connection is too slow. I didn’t submit a ticket as I am trying to avoid a return and what’s a few bucks. My main goal was to test the unit for our cinemavision kodi plugin for our upcoming certified units section.

I should have the external adapter in a few hours, I’ll report back if that solves the issue.


#4

Happy to report that the usb3 gigabit adapter solved all my streaming woes . But I think that kind of proves that the onboard networking is still having issues even after the september qa changes :frowning:


#5

Ideally it would be good to see iperf results before jumping to any conclusions. We haven’t had any further reports of defective devices after we added a QA step at the end of September.


#6

When I have a bit of testing time I’ll wrap my head around all the required testing to help out. I however dont think it’s jumping to too many conclusions when the onboard barely works and a usb adapter works flawlessly. I’ll have more time on monday I think and will submit all the tests. I do want to get it all properly sorted before writing the article. I imagine I will also be getting a secondary unit as the dongle out the side isn’t exactly beautiful. But I did want to post my results so that anyone who is having issues streaming over the network, usb adapter is a cheap, quick and easy albeit kinda ugly fix.


#7

I’m interested in your findings because the device has to pass several tests (involving the Ethernet port) before it can be shipped. Once we confirm you’re having a problem we can swap the unit over for you.

Sam


#8

I accidentally posted this in the PM so while I know it’s basically a dupe post I thought I should also post it here in case someone has the same issue

I decided to go ahead and run the test

iperf3 -R -c

funny enough the default adapter seems on paper to be much faster than the usb adapter. But everything still unplayable using the internal

External (Works)

[ 4] local 192.168.86.250 port 40154 connected to 192.168.86.50 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 38.4 MBytes 322 Mbits/sec
[ 4] 1.00-2.00 sec 38.4 MBytes 322 Mbits/sec
[ 4] 2.00-3.00 sec 38.3 MBytes 321 Mbits/sec
[ 4] 3.00-4.00 sec 37.8 MBytes 317 Mbits/sec
[ 4] 4.00-5.00 sec 38.3 MBytes 321 Mbits/sec
[ 4] 5.00-6.00 sec 38.1 MBytes 320 Mbits/sec
[ 4] 6.00-7.00 sec 38.3 MBytes 321 Mbits/sec
[ 4] 7.00-8.00 sec 38.3 MBytes 321 Mbits/sec
[ 4] 8.00-9.00 sec 38.3 MBytes 321 Mbits/sec
[ 4] 9.00-10.00 sec 38.3 MBytes 321 Mbits/sec

[ ID] Interval Transfer Bandwidth
[ 4] 0.00-10.00 sec 383 MBytes 321 Mbits/sec sender
[ 4] 0.00-10.00 sec 383 MBytes 321 Mbits/sec

Internal (Unplayable)
[ 4] local 192.168.86.247 port 41538 connected to 192.168.86.50 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 108 MBytes 908 Mbits/sec
[ 4] 1.00-2.00 sec 110 MBytes 919 Mbits/sec
[ 4] 2.00-3.00 sec 110 MBytes 922 Mbits/sec
[ 4] 3.00-4.00 sec 110 MBytes 919 Mbits/sec
[ 4] 4.00-5.00 sec 110 MBytes 920 Mbits/sec
[ 4] 5.00-6.00 sec 111 MBytes 928 Mbits/sec
[ 4] 6.00-7.00 sec 110 MBytes 920 Mbits/sec
[ 4] 7.00-8.00 sec 111 MBytes 932 Mbits/sec
[ 4] 8.00-9.00 sec 110 MBytes 926 Mbits/sec
[ 4] 9.00-10.00 sec 110 MBytes 923 Mbits/sec

[ ID] Interval Transfer Bandwidth
[ 4] 0.00-10.00 sec 1.07 GBytes 922 Mbits/sec sender
[ 4] 0.00-10.00 sec 1.07 GBytes 922 Mbits/sec receiver

So on paper internal seems to be rocket fast, so I imagine it passed the tests. But at least everything is rock solid (real world playback) using the external Ethernet. Not a skip no buffering.


#9

The Ethernet adapter looks good.
Try and play something with the internal adapter and post a log if you have issues. We will work it out.


#11

https://paste.osmc.tv/zucacipecu


#12

out of curiosity … how is the playback performance with onboard WiFi …?


#13

It looks like the basic networking is working on the Vero4K+. However, the definition of your video sources could probably be improved.

You have defined Kodi-based video sources:

     nfs://192.168.86.33/volume1/NAS_Movies/Movies_UHD/
     smb://192.168.86.240:445/Movies/Movies_HD/
     smb://192.168.86.33:445/NAS_Movies/Movies_UHD/

and fstab-based sources (though they are incorrectly specified):

192.168.86.33:/nfs /mnt/volume1/NAS_Movies nfs noauto,x-sytemd.automount 0 0
192.168.86.54:/nfs /mnt/Movies nfs noauto,x-systemd.automount 0 0
192.168.86.54:/nfs /mnt/Movies1 nfs noauto,x-systemd.automount 0 0
192.168.86.54:/nfs /mnt/Movies3 nfs noauto,x-systemd.automount 0 0

I see three different IP addresses and 192.168.86.33 has both NFS- and SMB-based shares. All in all, it seems a bit mixed up.

I’d recommend you rationalise your data sources and, if possible, use fstab-based sources.


#15

Sorry I didn’t reply yesterday. I guess after seven posts you can’t post again for 19 hours. I was playing with different share ideas while troubleshooting so when I get back into town I can post fresh clean logs. I am happy to report that we played 4k remuxes all day yesterday with the external Ethernet adapter and it never buffered or skipped once.

So problem is basically solved, hopefully the internal ethernet will work after an update or more troubleshooting, but for now a simple $10 fix made the Vero 4K work. I don’t know why I would have to do fstab mounts etc to get the internal Ethernet to work properly when smb shares work perfectly fine with the usb adapter.

@andodearg Wifi performance is actually faster than the nvidia shield. 1080 remuxes worked fine over wifi and was much more reliable than the built in ethernet port. 4K movies were a bit too much for the wifi connection though.


#16

I have updated your member status so you should now be able to post at will.

From what I can see from your tests there isn’t anything wrong with your internal adapter. But if you’re happy with the external adapter then we are happy. My guess is that you have a localised network issue. It would be simple for us to see what that is if we had some logs when you experienced problems with the internal adapter.

Sam


#18

Hi,

I did post logs and I am not exactly thrilled that I have to use an external adapter thats 1/3 as fast as the internal and sticks out the side but the device does handle correct framerates and color space so I am happy about that. But having to reconfigure my network or something to get the internal adapter to work is fairly unappealing when on the 1/3 speed external it’s been flawless after almost 20 hours of testing. I did try a new test as I have 2 netgear switches a 10gb main switch and 1gb switch where the media players for testing are. I ran a brand new cat 7 cable from the main switch to the vero with the same stuttering results. Plugged back in the usb ethernet adapter and it all works fine again. All I can figure is that the established testing methods are not uncovering the root problem with the internal Ethernet port.

So, I am happy that I was able to get it to work and work well, and as soon as a new product or chipset comes out hopefully that will fix things, but I can’t wrap my head around my network is configured wrong when it works fine on everything including the vero (external ethernet adapter), the only device with an issue is the built in ethernet port.

I would say that the vero is an awesome player with USB drives and just so/so with network drives out of the box. But that can be fixed if you don’t mind cables coming out of the side. Looking forward to the next iteration of hardware.


#19

Can you show me where the logs are? I must have missed this.

I don’t think this is an accurate assumption to make. We haven’t received any reports of defective units since we introduced our additional QA step. Since then, we’ve shipped several thousand units.
Your iperf tests show that the Ethernet adapter is working as expected. I also hand checked a few units from the batch your unit shipped from and could not find an issue. Customers seem to be powering on units from that batch now, so if there is indeed a problem, I would have expected to see it by now.


#21

Ok


#22

Thanks – it will be good to take a look at the log when you experience a problem and advise accordingly.

Sam


#23

Back in post #10 you provided a log. In it, I can see that you had:

  • the internal wired connection (eth0) connected;
  • the external adapter (eth1) not conected; and
  • wifi (wlan0) also connected.

I can also see a sequence of events that suggests the wifi connection was being used as the default route, rather than the wired connection:

Nov 01 12:00:59 osmc connmand[388]: eth0 {del} route 0.0.0.0 gw 192.168.86.1 scope 0 <UNIVERSE>
Nov 01 12:00:59 osmc connmand[388]: wlan0 {add} route 0.0.0.0 gw 192.168.86.1 scope 0 <UNIVERSE>
Nov 01 12:00:59 osmc connmand[388]: wlan0 {del} route 0.0.0.0 gw 192.168.86.1 scope 0 <UNIVERSE>
Nov 01 12:00:59 osmc connmand[388]: wlan0 {add} route 0.0.0.0 gw 192.168.86.1 scope 0 <UNIVERSE>

So, in order to test the main wired connection properly, you’d need to disconnect both the lan adapter and wifi - and then see if the video problems persist.


#24

This was the log when trying to play over the internal. The drives were a bit messy as I was trying multiple configs on the mounting and two different NAS units. Like I said, it’s 100% fine using external, i have used it every day. All I got when I posted this was use fstab mounts. But I don’t have to use fstab mounts to get it working using the external adapter. So either the internal is EXTREMELY finicky or just broken. Either way I have to try every device that plays kodi for our software and the ONLY issue with accessing the NAS videos is the VERO internal ethernet.