External HDD Automount

#1

I have a 4TB external HDD (WD Blue label) with movies on it and it has its own power supply but it will not show up on my Vero 4k+. I have tried formatting it with both exFAT and NTFS, but the drive does not mount. I have even tried using a different HHD enclosure but still nothing.

The HDD does show up on both my Windows 7 and Windows 10 laptops with no problems.

0 Likes

#2

Provide logs either via MyOSMC or grab-logs -A an quote the URL.
Also what is output of sudo fdisk -l | paste-log

0 Likes

#3

https://paste.osmc.tv/owepijeton

https://paste.osmc.tv/usipavanib

0 Likes

#4

Mar 16 23:03:09 Vero udisks-glue[526]: Successfully automounted /dev/sda1 at /media/Flo Backup

Looks OK, so you can not find it at /media/Flo Backup?

Maybe try to give it a label without space in it.

0 Likes

#5

The Flo Backup is a different external hdd I tried (WD Passport) and it mounted. However, the 4TB WD Blue will not mount to osmc, but does work in Windows laptops just fine.

0 Likes

#6

Would help if you only have the none working one connected when doing troubleshooting.
Check output of lsusb
Also maybe try different USB cable

0 Likes

#7

I’m using a different cable and still nothing. I tried lsusb but was returned “-bash: lsusb: command not found”, so now I’m trying to figure out that issue…

0 Likes

#8

lsusb belongs to the usbutils packet, so try

sudo apt-get install usbutils

0 Likes

#9

Thanks, that worked! lsusb returns:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 04fc:0c25 Sunplus Technology Co., Ltd SATALink SPIF225A
Bus 001 Device 002: ID 1997:2433
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

0 Likes

#10

Searching for that device there seems quite some bugs. Didn’t see if they are fixed lately

https://www.google.com/search?q=satalink+spif225a+Linux

0 Likes