External HDD connected to router not recognized by pi2/osmc

Hi friends,

i have this problem: i connected an external USB HDD WD 1TB to my TP-Link W8970 and configure it in storage sharing.
IP address of modem-router is and the path to reach the shared folder is //
From my pc with windows 7 i can reach it without problems, but from my Pi2 with osmc i can’t see it (I tried to reach it through smb://). I’m newbie in Pi world and i would have some suggest by experts like you!

Thanks for all


Login to OSMC via SSH

then execute the following commands and let us know the outcome

If that gives you a (positive) reply than try the next step

sudo apt-get install smbclient (no need to tell us the output

smbclient -L

Thanks fzinken, i know SSH, i usually use it with Putty in Windows. Today i’ll try to do your suggested steps and will post here results of all.

Thanks again

Hi fzinken, i tried to do your suggests.
Ping retried me a positive call, so i made next step. After smbclient was installed i gift this command:
smbclient -L and the system required me a password (i don’t know which password the system want)…i left the terminal and went to OSMC, i tried to connect a network unit and i put the IP address and the shared folder and now OSMC can see it.

Can you explain what i do and if these steps are needed in anyhow to se shared folders in HDD plugged to modem-router?

Thanks again

No the steps you did would just be for troubleshooting so I guess you just had a temporary connection issue

ok, thanks.
And if i want to mount automatically this path after every boot of pi? What do i have to do?

Well if you add it to the library via SMB in Kodi it will be automatically be mounted (or at least made available).
If you want to permanently mount it to a location that you first need to create a folder and then add this to /etc/fstab

//<share> /mnt/<mountpoint> cifs x-systemd.automount,noauto,iocharset=utf8,user,uid=osmc,gid=osmc,iocharset=utf8,file_mode=0770,dir_mode=0770 0 0

Hi fzinken, just for information: it seems that the problem was wifi. Initially, osmc was connected to the network through wifi adapter and there was issue that i had described in previous post. Yesterday evening i unplugged wifi adapter and connected osmc through cabled network. Now all issues is resolved. I can see, copy, etc… shared folders through osmc.

thanks a lot