External HDD fried


I have set up OSMC Alpha 4 on my raspi B, and got it working yesterday. Today, I plugged in my external HDD, a Storejet Transcend 1TB, added the films folder to the library, and refreshed the library. So far so good, films start appearing.

However, at this point, my housemate started up an app (Sybu Kodi, IOS 8, iPad) and tried to set a film playing. The pi stuttered a bit, and then brought up a message which said “Busy”, and had a bar pulsing back and forth After about 30 seconds, the bar stopped moving. I waited about ten minutes, and nothing had happened. I ssh’d into the pi, and rebooted it manually, as it had become unresponsive to both app and keyboard input. Words were had.

At this point, systemd ran a stop job on the hdd, which kept extending, and lasted for over five minutes. It then showed the shutdown target reached message, but kept showing “async write failed” messages relating to the HDD in a cycle, every ten seconds or so. After a few minutes of this, I killed the power to the pi, and restarted it again. To my dismay, my HDD will now no longer mount on the pi, and also will not mount on any of my other computers (which I have tested it with in the past). In fact, the drive is no longer visible through fdisk -lu, dmesg, or lsusb, and the power LED does not turn on when it is plugged in.

Do you have any idea what might have happened? I have never seen anything like this before, except in cases of HDD failure. It makes no noise (it’s a platter-type), and is a high-quality drive which is only a few months old. I would not have expected it to fail for at least another few years.


Having listened closely, I can hear the drive power up and start seeking, and not in an obviously repetitive way.

Can you pull the drive from the case and connect it internally to a pc?

A few years ago, I had an external desktop 1TB IOMEGA HDD, and
one day something similar happened. I was using it connected to a Windows PC.
I reckoned the HDD controller had failed, because I was able to
remove the HDD and connect it to another external power supply. the
disk just wouldn’t even spin up.

I didn’t try swapping the controller with another one, but in retrospect, I think
that might have worked.

Was your external HDD powered by external power supply, or powered by
the Pi? Maybe if there was not enough current getting to the HDD, it might
have damaged the HDD controller?

You could try buy another HDD of the the exact same make, and try swapping
the controller…? That is if you really, really need to retrieve what was
on the disk.