External HDD mount

#1

Hi, I’m trying to access an external HDD USB3.0 from osmc latest version. I can’t see it. In terminal I launched :

osmc@osmc:/$ lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 7.3T 0 disk
|-sda1 8:1 0 16M 0 part
`-sda2 8:2 0 7.3T 0 part

mmcblk0 179:0 0 14.9G 0 disk
|-mmcblk0p1 179:1 0 63M 0 part /media/RECOVERY
|-mmcblk0p2 179:2 0 1K 0 part
|-mmcblk0p5 179:5 0 32M 0 part /media/SETTINGS
|-mmcblk0p6 179:6 0 80M 0 part /boot
`-mmcblk0p7 179:7 0 14.7G 0 part /

One is my sd card the 7.3T is my external HDD. I can’t access because isn’t mounted. Why is it unmounted? Can I access it?

I tried to report also

sudo fdisk -l

but I think this freeze my shell… without sudo:

cannot open /dev/sda: Permission denied

HDD works fine with Windows.

Thanks.

#2

Does it have its own power supply? Otherwise I suggest to use a powered hub

#3

Yes, it has an external power supply .

#4

Please post some logs

#5

[ 21.284965] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[ 21.285365] sd 0:0:0:0: [sda] 15628052480 512-byte logical blocks: (8.00 TB/7.28 TiB)
[ 21.285377] sd 0:0:0:0: [sda] 4096-byte physical blocks
[ 21.285907] sd 0:0:0:0: [sda] Write Protect is off
[ 21.285916] sd 0:0:0:0: [sda] Mode Sense: 47 00 10 08
[ 21.286493] sd 0:0:0:0: [sda] No Caching mode page found
[ 21.286505] sd 0:0:0:0: [sda] Assuming drive cache: write through
[ 21.289859] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[ 22.266122] sd 0:0:0:0: [sda] tag#0 UNKNOWN(0x2003) Result: hostbyte=0x00 driverbyte=0x08
[ 22.266148] sd 0:0:0:0: [sda] tag#0 Sense Key : 0x3 [current]
[ 22.266155] sd 0:0:0:0: [sda] tag#0 ASC=0x11 ASCQ=0x0
[ 22.266167] sd 0:0:0:0: [sda] tag#0 CDB: opcode=0x88 88 00 00 00 00 03 a3 81 27 d8 00 00 00 08 00 00
[ 22.266179] print_req_error: critical medium error, dev sda, sector 15628052440
[ 22.266187] Buffer I/O error on dev sda, logical block 1953506555, async page read
[ 22.266244] Alternate GPT is invalid, using primary GPT.
[ 22.266313] sda: sda1 sda2
[ 22.271089] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[ 22.272678] sd 0:0:0:0: [sda] Attached SCSI disk

This is the only information I found in my log…

#6

Obviously this device has a problem at least in the last area of its sectors. You need to first check your HDD … which will be a painful longish process with that size:

  • try chkdsk /r on Windows (I’m not too convinced about that but it is a present onboard tool with Windows)
    or
  • might be better: Go to the HDD’s vendor support page and search for a vendor specific tool to do this scan job detecting and repairing bad sectors
    or
  • try smartmontools which runs on OSMC and Windows and do a long test smartctl -t long .... You need to prevent the specific OS to hibernate the USB HDD by running any IO activity in loop every 60 seconds or so. So, a simple script doing a periodic smartctl -i or smartctl -aor creating’N deleting a file on the HDD’s file system is doing this. smartctl only helps to detect a defect sector and typically stops on first found, it does not repair anything. So, if you find pendingor uncorrectable sectors afterwards or see a lot of reallocated sectors you’ve to take a decision.

Imho, I personally see HDDs as untrustworthy once the first defect sectors occur.

#7

I tried to launch chkdsk /r but it’s a long process I think today I haven’t time to do it. The HDD is in exFAT, could be this the issue? Thanks

#8

I don’t think so. Your posted info more suggests at least one bad sector on the disk, see also this link.

Don’t know whether the fuse module cannot handle this error in the alternate GUID Partition Table at the end of the hdd’s sectors … but just for tests I formatted a 1TB hdd using GPT and exFAT and all works as expected connecting it to an OSMC device (Pi3 B+).

#9

Thanks for test. So windows have no issue to works with this disk, I used crystaldiskinfo to have a green test to continue to use it… I don’t understand why osmc can’t use it…