External usb name

Hi,

My external harddisk is called 40GB. It is connected to my Pi with usb.
Since a few days it is called 40GB_ and now my films are not scraped into the database because of the naming conflict. How to get my disk name back to 40GB. How to resolve this?

Have you restarted your Pi?
There must be something blocking the original name unless you changed the disk lable.

remove the disk, delete the directory 40GB sudo rmdir /media/40GB and re-insert the disk.

I restarted several times and I also savely removed the drive.
When I add a new source in video/files I go to the folder root/media and I see 40GB even when no disk is attached. I have to unmount this I think, but I don’t know how to.

You must have created the folder I assume. Do I assume correctly you just use automount for the drive not manual fstab mount?
If so just follow advice from @grahamh

I didn’t create a folder.
Where do I run this command. With my laptop?

https://osmc.tv/wiki/general/accessing-the-command-line/

That folder gets automatically created when you insert a disk. If there was a bad shut-down it can stay there when it should be deleted by the system. Then when you start up the system has to invent a new name, hence 40GB_.

see https://osmc.tv/wiki/general/accessing-the-command-line then enter the command I gave you.

1 Like

yes I did had a bad shutdown.
thanks all. I have to read this wiki first.

1 Like

I managed to remove the directory. Now is all good.
THANKS

2 Likes

Hey guys,

i have the Same Problem like maxdido.
I tried to use the command from Graham, ist doesnt work for me.

Ist says there is no sich Directory.

image|689x318

Should be sudo rmdir /media/Seagate\ Expansion\ Drive right?

The Name of the Drive is

„Seagate Expansion Drive“

I used

sudo rmdir /media/Seagate Expansion Drive

but it doesnt work.

You need to escape the spaces with backslashes or quotes.

"/media/Seagate Expansion Drive"

thx for your help. Nice weekend