Extremely slow after December 2018 upgrade

Hey, new Vero 4K + owner here. It was running on August 2018 build and everything was super smooth until I updated to the December build. Now everything is sluggish, wifi/nfs is absurdly slow, everything seems to be buffering all the time.

Anyway I can rollback to the August build easily?

It’s not that easy. It would be better if we can solve your networking issue for you. First check in MyOSMC if you are using the fastest wifi connection (ie 5G if you have it). After that, do you know how to use ssh and iperf?

Can you post a log via My OSMC so we can check things?
Ideally as @grahamh says it – it’d be better to fix things with the version you are using; particularly as we haven’t really had any reports of this.


After a router reboot it seems to have resolved itself, temporarily. In fact I get the same problem as I experienced after some idle time: wifi connection becomes extremely slow, dropping down to the kilobytes/s measurements. I’ll do a bit more investigation but yes, I am quite capable of ssh’ing or running iperfs.

A reboot always fixes the problem but as the box sits idle the problem creeps back… until the next reboot.

My experience is that this is more often than not indicative of a router on its way out. I’ve seen people live with this issue and constantly reboot their router for well over a year before the thing craps out entirely. What router are you using? Have you recently upgraded the firmware on it?

That seems doubtful. All my devices work fine, my rpi3 (which the Vero replaced) worked perfectly fine.

BTW this is not about rebooting the router. It’s the Vero that needs rebooting.

Hard to speculate without a log.
Have you tried given Vero a minute off at the mains?