Extremely slow network

All of a sudden, I’m getting very slow response when trying to watch something on my NAS. The network link between the NAS and the Vero4K is a powerline adapter through a couple of routers. I haven’t changed anything.

If I go to watch a tv show that I have stored on the NAS, it will take a good 60 seconds or more before the it starts. Watching the show, pausing, etc is fine once it starts.

I ran iperf3 and when I do it Vero4k to NAS I get about 36Mbits/sec and when I do it NAS to Vero4k I get abound 20Mbits/sec.

I’m unsure if speeds are considered slow or not.

Are there any tips on getting a quicker response to trying to watch something?

Unplug the power line adapters and allow them to reboot.

1 Like

That only partially worked. I installed the powerline networking app and changed a couple of settings and now get around 155 Mbits/sec.

This has not helped with how quickly a TV show or movie loads. Running a speed test in Kodi just sits there.

Using the TV’s web browser, I’m getting these speeds

These are both using the same router, powerline network, etc.

Lastly, the speed from my computer with a direct connection which is clearly faster, but still, something funny is going on with the Vero.

You’ll have to provide logs then so others may have any chance of giving relevant guidance.

Thanks, the logs are viewable at https://paste.kodi.tv/pawonaxodu

I’m not seeing where your getting a 60 second delay…

2023-08-16 17:21:19.794 T:2763    debug <general>: HandleKey: return (0xf00d) pressed, window 10106, action is Select
2023-08-16 17:21:20.012 T:2763    debug <general>: OnPlayMedia nfs:// 03/Alone.S03E05.The Lone Wolf.mkv
2023-08-16 17:22:24.738 T:2763    debug <general>: OnPlayBackStarted: CApplication::OnPlayBackStarted
2023-08-16 17:22:25.631 T:2887    debug <general>: ActiveAE::SyncStream - average error of -81.004963, start adjusting

I see less than a second from when you pressed the button on your remote until Kodi initiated playback, and around five seconds from there to when Kodi is playing the file and syncing the audio.

This is despite you running a library update at the same time and probably getting delayed by both the upnext and embuary helper add-ons doing stuff at the same time the video is starting.

This is truly weird.

The tv show I tried to play (as seen in the log file) is about 500Mb. I then tried playing a 25Gb movie file. Both take about 60 seconds between pushing the button on the remote (and hearing the little notification noise) and the file starting to play.

If it is not a network issue, what else can it be? As I said before, this is a new thing - it used to be near instantaneous to start playing.

How are you determining it to not be a networking issue? You stated out saying you got as little as 20mb/s which is very slow and then said your getting 155 (which still isn’t exactly very good) but didn’t say if this was from an iperf from your NAS to your Vero 4K+ which is really what you want to determine. Also, what exactly are we supposed to go off of? The only log you posted was just the Kodi log and not a full log set and it did not contain an example of you reproducing the issue. I’d venture a guess that your network connection is perhaps not very stable speed wise and a slow connection combined with large files is requiring additional buffering time, but this is just a guess.

1 Like

I just assumed that the huge file size difference having the same result in delayed playback meant it was something else. Clearly I’m wrong.

I also didn’t realize that 150 Mbps is particularly slow as it presumably has always been this and was sufficient to start playback immediately. You’re right though, I didn’t include the iperf3 numbers and only trusted the powerline software.

I don’t know what other logs to include to help.

As requested, here are the iperf3 numbers.

NAS side:

Vero side:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

My apologies, I previously used another log uploader which must not have uploaded everything. This time I did it with the one in My OSMC

The relevant log is at https://paste.osmc.tv/etukowusuh

The video file I used to recreate the problem was Alone.S03E07.Hungry Beasts.mkv

You need to install a newer version of this add-on which supports Python 3.9:

The Kodi speed test isn’t very useful in this context anyway - it measures the speed at which Kodi can pull data from the Internet. But what you want to know is the speed at which it can pull data across the local network from the NAS. Using iperf3 will give you that.

1 Like

And if you stop the library update before you tell the file to play? There is almost 300 log entries from the scraper between the time when you told it to play a file and when the file started.

I have installed the updated internet speed test and it now works. I’m getting 75 Mbps up and down.

I disabled every library update add-on or setting I could find and the minute long delay still happens when starting a show.

I did notice that when I push play, the constantly updating text in the upper left (visible when making a debug log) completely freezes until the show starts up when it continues as normal.

The latest log file is at

Can you disable the embuary helper add-on and see what impact that has? That is the only thing I see going on in that time period.

Disabling Embuary Helper didn’t help.

I also tried disabling the wired network connection and using wifi but it has the same problem.

This sounds like a somewhat more complex infrastructure.

Can you temporarily connect the Vero without a TV to the same switch that the NAS is connected to?

  • If the iperf3 bandwidth test is then ok, the problem lies somewhere in the rest of the infrastructure.

  • If the iperf3 test is still bad, the problem can only lie with the NAS or the Vero itself. An iperf3 test between the Vero and another device should then show on which device the error must be sought.

Tip: The iperf3 device showing the Retry and Congestion Window columns in the output, is the sender. We want that the NAS is the sender means the iperf3 server runs on the Vero side without any additional options and the NAS is the iperf3 client.

You might take one of these larger files that consistently starts slow and put it on a thumb drive or similar and see what happens when played without the network at all. This should help determine if this is something having gone sideways with your box or a networking issue.

1 Like


I did experience the same odd situation with my Vero 4K connected via cable to my router last year.
Suddenly the playback was choppy and with iperf3 I could see a degeneration of speed.

After testing around I finaly found a solution. The router was the problem. In my case a Fritzbox. I needed to reset the router and once done everything worked again on max speed aka 1Gbit.

Not sure about your setup but it was the router and not the NAS / Vero.