Fail after upgrade

Hi there.
Yesterday I upgraded my system on raspberry pi 3b+:
[UPGRADE] armv7-eventlircd-osmc:armhf 1.3.9 -> 1.4.3
[UPGRADE] armv7-network-osmc:armhf 1.7.6 -> 1.7.7
[UPGRADE] base-files-osmc:armhf 2.8.6 -> 2.8.7
[UPGRADE] libbluetooth3:armhf 5.43-2+deb9u1 -> 5.43-2+deb9u2
[UPGRADE] libicu57:armhf 57.1-6+deb9u3 -> 57.1-6+deb9u4
[UPGRADE] mediacenter-skin-osmc:armhf 18.2.0-30 -> 18.2.0-37
[UPGRADE] perftune-osmc:armhf 1.2.4 -> 1.2.5
[UPGRADE] rbp-bootloader-osmc:armhf 3.1.0-1 -> 3.3.0-1
[UPGRADE] rbp2-mediacenter-osmc:armhf 18.5.0-4 -> 18.6.0-5
And something went wrong:

https://paste.osmc.tv/zezineyeka

ssh works, everything works except Kodi user interface.
Anyone knows anything about recent buggy updates?

Hi,

It seems like your SD card may be problematic.

Some SD cards are not genuine or have a lower capacity than advertised. Some simply fail over time.

Symptoms of SD cards not working correctly are:

  • Read-only behaviour, or changes made not persisting
  • A filesystem corruption error

Symptoms of counterfeit SD cards are:

  • Writing works until a certain filesystem size is reached, thereafter, writes seem to cause issues where existing data is lost or newly written data is not preserved.
  • SD card fails after a short amount of time.

Counterfeit cards are usually found on Amazon and eBay.

SD cards have a limited lifespan. I recommend you change SD card and suspect that issues will no longer persist with a good card. If you would like to be a good quality SD card purpose manufactured for OSMC, then you can find one in the Store.

I Use SSD with NOOBS+OSMC
System works, but UI can’t start…

Try reinstalling Kodi:

sudo apt-get install --reinstall rbp2-mediacenter-osmc

If you’re using the OSMC skin, try to reinstall that too:

sudo apt-get install --reinstall mediacenter-skin-osmc

(Edit. I see you’re using Estuary.)

On a separate note, you’ve installed Network Manager, which will conflict with connman.

Does it can produce that kind of system behavior?

BTW, network working good…
Workaround with packets didn’t help, sad but true. Where I can find some logs, that points at error?

Kodi skin, that you use.

1 Like