Fail to reformat 4k - segmenation fault or "stuck on installing files"

I want to factory reset my Vero4k back to it’s original settings.

I downloaded the latest image 2020-11-01 and the OSMC installer to create a boot image on a microsd

One of two things keep happening either it get stuck at this point… I waited an hour just in case …


or this happens:


I am using the original power supply with no devices attached except the remote dongle.
2021-04-27 12.42.43 (Small)

I reformatted the SD card twice to make sure that the installation media wasn’t corrupted

Any ideas?

Can you by any chance try a USB Stick to ensure it’s not the SD Card?
Did you had problems before or why do you want to reinstall?

Thanks for the reply.

Using a USB stick results in segmentation fault as well.

The vero was unused (and powered down) for over a year. I thought I’d get it back in use and start with a clean install

Doesn’t sound healthy, maybe @sam_nazarko has an idea.
If you have a comparable power supply try that to exclude as reason.

So but if you boot without the SD Card is it still booting?

It’s possible you were on a really really old version before and have an outdated bootloader.

Do you remember the last version you had installed?


I don’t know which build it was on before, but it’s definitely not been turned on for 1 year. I did keep it updated at that time.

The strange thing is I left it on the frozen screen for about 2 hours, when I came back it had re-booted itself back to the OSMC set up screen.

I suppose it is safe to set up now ??

Give it a go.

I have the same thing with my friend’s vero 4k today…
I’ve used an usb stick and right now I am waiting for about 1,5h…
waiting still. screen is stuck on “installing files”.

I will hang on for a while. this vero was also inactive for a long time.

nothing :frowning:
can you make older IMG available?
maybe old vero devices struggle to get reinstalled with newer images?!
I have no clue.

I tried ubs 3.0 stick, usb 2.o stick and micro SD.
2021 images and 2020 images…
all operations fail.

any idea how to get things running again?

cannot explain how, but I managed to do the fresh install.
usb 2.0 stick was key at the end…(seems like)
but I have no real clue. strange. I got 10 errors before and my last try worked out.

It’s possible the image that you downloaded was corrupted.
There shouldn’t be issues installing newer versions of OSMC on any version of Vero 4K/4K+