[failed] failed to start /etc/rc.local compatibility

My vero 4k wasn’t working properly today so I restarted it and saw this line

[failed] failed to start /etc/rc.local compatibility

sudo systemctl status rc-local gives me this display

osmc@osmc:~$ sudo systemctl status rc-local

  • rc-local.service - /etc/rc.local Compatibility
    Loaded: loaded (/lib/systemd/system/rc-local.service; static; vendor preset:
    Drop-In: /lib/systemd/system/rc-local.service.d
    Active: failed (Result: exit-code) since Sun 2018-09-09 23:14:18 NZST; 39s ag
    Process: 405 ExecStart=/etc/rc.local start (code=exited, status=203/EXEC)

Sep 09 23:14:18 osmc systemd[1]: Starting /etc/rc.local Compatibility…
Sep 09 23:14:18 osmc systemd[1]: rc-local.service: Control process exited, code=
Sep 09 23:14:18 osmc systemd[1]: Failed to start /etc/rc.local Compatibility.
Sep 09 23:14:18 osmc systemd[1]: rc-local.service: Unit entered failed state.
Sep 09 23:14:18 osmc systemd[1]: rc-local.service: Failed with result 'exit-code
Warning: rc-local.service changed on disk. Run ‘systemctl daemon-reload’ to relo

running latest update on a vero stock vero 4k. I haven’t changed anything on it so Im unsure why its doing this .


I would double check that rc.local is executable.

Also adding a sleep before the commands in rc.local may help.

Thanks Tom.

Have you changed rc.local? What’s the contents of it?

I haven’t done anything to it. Today it just decided to play up.
Its very stock/factory install. Running autofs but thats about it

How do I check if rc.local is executable and check contents??

cat /etc/rc.local (to check contents)
sudo chmod +x /etc/rc.local (to make executable)

osmc@osmc:~$ cat /etc/rc.local

#!/bin/sh -e
# rc.local
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
# In order to enable or disable this script just change the execution
# bits.
# By default this script does nothing.

exit 0

Nothing happens when I enter the executable line??

You won’t get visual feedback from that.
Try rebooting and seeing if the issue is gone.

Restarted and still getting the error.

Please can you upload a set of logs so we can check?

I wasn’t too sure which parts of the log to upload so I did the whole thing.


Sep 10 00:27:37 osmc systemd[1]: Starting /etc/rc.local Compatibility...
Sep 10 00:27:37 osmc systemd[407]: rc-local.service: Failed at step EXEC spawning /etc/rc.local: Exec format error

Please copy/paste the contents of /etc/rc.local and format it with the </> “preformatted text” button.