Failed Install to SD card

I am using windows 10 to attempt to install OSMC to an SD card. I intend to use on rasberry pi. The options I select are English > Rasberry Pi > version 2015.09-1 > on SD card> wireless connection> WPA>WPA2>My SSID>My Password>Select Proper SD drive> accept license> Then it asks me to re-download image file. If I pick yes I get the error “Download Failed! Please Check your network connection.” If I pick no it asks me do I want to extract again. If I pick yes it says “An error occured extracting the archieve! Please consult the logfile.” If I pick no it jumps to congratulations your ready for show time. But nothing is on the sd drive.

I deleted and reinstalled the installer twice. I have ran thru all the options numerous times. Same result.

Are you running as administrator?


Look in C:\users<youtusername> for a file named log.txt and post its contents. Also delete any files beginning with osmc from that directory and then try running the installer again

Also check the write protect switch is not accidentally set


I cleared the log to get a fresh one. This is redownloading the image file.

This is without redownloading the image file. Clicking yes to extract.

use 8-1
9-1 hasn’t been released yet.

Wow I have been wasting my time. Thanks 8-1 took off. Why is 9 an option if its not available?

It will be available soon.

September update (9-1) is available. I’d advise you download the instead of the August release. It should download fine now.


I tried 9-1 for the last hour. Maybe the host server is down. But 8-1 took off fine.

If the server was down, then the links would not load at all.

Your log shows you are trying to download the Raspberry Pi 1 version. If you try that in the installer now, I assure you that it will work :smile:

If you do use the August image, be sure to perform a full upgrade after booting


1 Like