Failed to create vout component

Shiny new installation of OSMC tonight - with all the latest updates from apt-get update … plus hyperion.

Each time I try to play a video my log file fills up with errors …

I hate to say it, but it was working with OE.

22:58:31  11.553444 T:1957175296  NOTICE: ARM mem: 944MB GPU mem: 64MB MPG2:0 WVC1:0

Set the GPU mem back to 256mb… This is your main problem… You’ve completely butchered the config.txt.

1 Like

Looks like you have edited config.txt and lost gpu_mem_1024=256

Apart from accidentally setting the memory allocation back to defaults, would you care to explain how the file is “completely butchered”?

You’ve “butchered” it compared to a default file. Your edits have lead to the mistake regarding the GPU mem… If what you want is bone stock default clocking… Enjoy…

Thanks Sam, that’s done the trick.

Are the recommended config.txt settings published anywhere? I tried to restore them using the Pi Config utility but of course restore to defaults sets the GPU memory back to 64…

Clearly I did a bad job trying to transfer my OE config settings.

Why would you think the config.txt settings from OE, which is using a different version of kodi, and a different OS with different loadings, applicable to OSMC?
The easiest way to get the settings is to install OSMC, and then copy the then current settings to a safe place for reference. Bear in mind that these can vary according to the hardware on which you install.

Jeez hostile forum much.

I was just trying to transfer some config.txt settings over pertaining to specific HDMI, EDID and CEC handling which I need regardless of the platform and inadvertently removed the memory stuff.

Since I don’t have a copy of the original settings I was simply asking if they were available, obviously I don’t have them otherwise I wouldn’t have asked.

No, not a hostile forum - just trying to help with advice for future, and also some info which you might not have been aware of.