Failed to Install FTP server from App Store

Running OSMC on Raspberry Pi B+ and tried to install FTP server from the App Store.
It failed to install multiple times.

I’ve uploaded the Log files to

Smoking gun in the log.
Sep 26 19:53:46 osmc mediacenter[285]: AttributeError: ‘Download_Progress’ object has no attribute ‘fetching’
Sep 26 19:53:47 osmc mediacenter[285]: 2015-09-26 19:53:47.081348 exception occurred
Sep 26 19:53:47 osmc mediacenter[285]: 2015-09-26 19:53:47.081534 exception value : Failed to fetch Size mismatch

Tried to install FTP server again today and worked perfectly.
One thing I know is that the PSU I was using previously was under powered so the failure may have been related to that.

For anyone who care. Hudl2 PSU works great with Pi1 B+ with external hard drive with max_usb_current=1 in config.txt

This means that there was a bug with one of the Raspbian mirrors. It seems to be resolved now.


Thanks. Yes. It worked when did it again today.
A lot faster than SFTP.
Happy Bunny