Failed to install Raspberry Pi 2 -- Could not mount filesystem!

I am attempting to install OSMC for a Raspberry Pi 2 using the OSMC Installer on Linux (running Debian + KDE). Everything goes fine right up until the installer attempts to remount the SD drive to write the preseed.cfg file, at which point the UI claims it cannot mount the card and must exit. Here is a log file for that attempt: http://paste.osmc.io/utopugodoh.pas

I’ve seen several other posts on the support forum about this, but haven’t been able to acheive a resolution. Here are answers to questions I’ve seen asked in the past:

  • Yes, I’m running the installer as sudo
  • Yes, I am able to manually mount the SD card
  • Yes, /tmp/osmc_mnt/ is being created
  • Yes, I have tried multiple SD cards
  • No, I haven’t tried a different card reader (I only have the on this laptop)
  • No, I haven’t tried the installer in Windows (this laptop is not dual boot)
  • No other application is trying to mount the SD card (more on that in a moment)
  • The SD card appears to have all the expected files except the preseed.cfg file

When I turn on the Pi, I get the rainbow colored square with no further activity.

Here’s some other interesting notes. I also have an Pi 1. When creating an OSMC image for that, I get the same mount error at the end. However, unlike the Pi 2 image, it boots fine in the Pi 1, but does require me to manually configure the wireless network. FWIW, inserting the Pi 1 SD into the Pi 2 just displays a black screen. Here’s a log file from the Pi 1 install: http://paste.osmc.io/owebemiruf.pas

An additional note, KDE does have an auto-mount feature, but it is off. There is a little notifier widget that gets REALLY excited right around when the installer tries to remount. It’s like the available devices is being refreshed a bunch and the notifier is just letting me know that, yes, that SD card is there for mounting. But it doesn’t appear to actually mount it at anytime.

Other than trying a new SD reader (which requires money I’d rather not spend, as the reader seems to work fine) what other approaches should I try? Is there something I can do manually to the SD card after the installer exits to get it into a working state?

Thanks for whatever help you can provide!

Have you tried just using a disk image, rather than the installer?
Use dd on your Debian install to just write the image to your SD card. That’s what I do every time and I have had zero issues.
https://osmc.tv/download/

  • How big is the SD card?

I haven’t tried to used dd, but when doing so, is there anything you need to do after running dd to enable the SD card to actually boot in the Pi 2? The rainbow screen gives me the sense that it’s just hanging while looking for bootable media.

As to the SD size question: I’ve used both a 16GB and an 8GB card, both with the same results.

Are you sure you have a Pi 2?

No. The SD card will work just the same as the installer version without the preseed file. That is, you will have to set up the network etc manually.