Failed to transfer tar file

Hi.

on vero 4k my auto backup is not working properly.

in the setting i select auto backup at 06:00am and only keep 1 backup file

but my old backup is still here and does not get overwritten.

so every day i get the message “failed to transfer tar file” and i have to klick ok and after that the system is again checking for updates. But my new backup tar is not in my backup folder, it still contains the old file.

these are the log outputs of the update progress:

http://paste.osmc.io/uketenicum.vhdl

thanks

Where abouts are you saving the backup to and what are the permissions on that folder/files?

i created the Folder Backup directly in the osmc directory (same as on Vero2) so i don’t changed anything

drwxr-xr-x 2 osmc osmc 4096 Mär 24 08:54 Backup

The snippet of logs you have provided are of no use as they do not include the requisite part of the process.

Please supply a FULL set of debug logs using grab-logs -A after replicating the problem with debugging enabled.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

any other ways to do this? I get the following error:

osmc@vero4k:~$ grab-logs -A
Logs successfully uploaded.
Logs available at http://paste.osmc.io/{“message”:"Documentexceedsmaximumlength.

Reboot a couple of time.

Some of your logs are too big.

ok but when the logs now will be deleted i can post this the next time (tomorrow)

Because my log even is to big to upload, i uploaded the whole kodi.log to download external.

If i delete the old backup file in the folder i can make a manual backup but everytime the automatic update is running i got failed to transfer tar file. Must be something with the rights.

Is the backup process not running with root?

http://www97.zippyshare.com/v/YsJfJXBp/file.html

That is a big file!

Line 112,041 shows this:

06:23:53.491 T:3864531952   ERROR: Copy - Failed write to file /home/osmc/Backup/OSMCBACKUP_2017_04_04_06_00_41.tar.gz
06:23:56.383 T:3864531952   DEBUG: OSMC BACKUP:  :  - Transfer of backup file not successful: 0

Failed to write file is likely either as a result of permission issues or lack of space.

But look at this:

06:00:41.250 T:3864531952   DEBUG: OSMC BACKUP:  :  - local required disk space: 3440218344
06:00:41.250 T:3864531952   DEBUG: OSMC BACKUP:  :  - local available disk space: 5329006592

Your backup file is 3,440,218,344 (about 3.4 GB) in size and you have about 5.3 GB of space. That’s a very large backup. I’m not sure why it’s failing to copy the file but you should seriously consider excluding some categories of data and/or writing it to an external thumbdrive or network drive.

ok, i will try to backup to a external NAS Drive.

I set the Backup Shedule to backup every day at 6am and only keep 1 Backup, so there should be only the newest file and i think there is a problem with deleting the old backup file.

I will try this on the NAS.

Thanks

Don’t backup the thumbnails. I don’t think it is worth it.

The thumbnails are not included in the Backup.

Today the backup worked, i will report if the update of tomorrow can overwrite the existent backup on the NAS.

Wow, what are you storing that takes up that much space?

Nothing special.
addon_data 2.6GB ← but if i delete it i think i get a problem :smile:
addons 728MB
Thumbnails 650MB ← but i don’t backup this folder
Database ← 50MB

What addon is storing that much data?

artwork downloader has 1.1GB and i use Aeon MQ7 Skin with animated fanarts. So the Artwork downloader is needed for this skin.

You may want to consider moving that folder and sym-linking it. That will drop it from the backup file I think.

Ok thanks, good idea.

Btw, the Backup on the NAS worked fine the 2nd day so the problem is solved.

thank you.