Failed update breaks video playback

I have a Vero 4k+. For the second time since I got it, I’ve had a failed update that completely breaks HD video playback with the CPU load at over 300%. Is there anything I can do to fix this short of reinstalling Kodi? Here’s the log file:
Thank you for any help.

Sounds like an incomplete update, try updating again.

I can check the logs later.

Hi Sam, I don’t think it’s possible, if I scan for updates it says there are none available and the OSMC version is shown as February 2024.02-1 as if it thinks the update worked.

I would suggest to ssh into your Vero from a PC and run…

sudo dpkg --configure -a
sudo apt-get update
sudo apt-get dist-upgrade

and let us know if that still returns errors.

1 Like

This will definitely fix it, provided the user has rebooted first, but the update should have done this already.

Looks like the user didn’t have enough free memory to complete the update.

Could have been caused by a memory leak by a problematic Kodi add-on or too much memory pressure from other services on the device.

@darwindesign Thanks so much, that worked perfectly.

Is there any way of finding out what’s using the memory? I don’t run that many add-ons really.

1 Like

I wouldn’t worry about it unless this remains an ongoing issue. I’d venture a guess that you may have just had your system running for a particularly long time which up until a few updates ago could cause this problem. As you hadn’t updated previous to this for a year you wouldn’t have had that issue patched yet.

You said this occurred since the second time you got it an update had been broken.

When was the last time this occurred?

Looking at my search history I think it was around July 30th last year.