Failing to install OSMC on USB stick (Pi3)

Hi all,

I’m a newbie to RPi, Linux and OSMC and need some help to install OSMC !

Here what I want to do : install OSMC on my RPi3 to get a homemade multimedia server and then install Nextcloud on OSMC to get a home cloud in the same time. As I’ve read that SD Cards don’t last very long I’d like to install OSMC filesystem on a USB stick.
I bought a 4TB USB Stick (Seagate BarraCuda) and have formated it in GPT with 2 ext4 partitions (20G dedicated to the OS and Nextcloud and 3.6T dedicated to my media files). My SD Card is a 16Gb class 10 included with the RPi pack I bought.

After many many hours failing at doing this and seeking answers in many forums I request here your help !

What I did :

  • installed first raspbian and formated my USB stick as mentioned above
  • formated my SD Card with SD Card Formatter on Windows
  • downloaded the OSMC installer for Windows
  • Ran the install program, chose the install on USB stick and wireless connection. Everything seems ok here.
  • Boot the SD Card on my Pi, everything seems ok since I get that message on the screen : “Install failed : can’t mount root”
    Here is the install.log :

Thu Jan 1 00:00:07 1970 Starting OSMC installer
Thu Jan 1 00:00:14 1970 Detecting device we are running on
Thu Jan 1 00:00:14 1970 Mounting boot filesystem
Thu Jan 1 00:00:14 1970 Trying to mount to MNT_BOOT (/mnt/boot)
Thu Jan 1 00:00:14 1970 Using device->boot: /dev/mmcblk0p1 and FS: fat32
Thu Jan 1 00:00:14 1970 Preseed file found, will attempt to parse
Thu Jan 1 00:00:14 1970 Found a definition for storage: usb
Thu Jan 1 00:01:21 1970 Creating root partition
Thu Jan 1 00:01:21 1970 From a root partition of /dev/sda1, I have deduced a base device of /dev/sda
Thu Jan 1 00:01:21 1970 Must mklabel as root fs is on another device
Thu Jan 1 00:01:21 1970 Going to mklabel with device: /dev/sda with a label type of MSDOS
Thu Jan 1 00:01:22 1970 Calling mkpart for device: /dev/sda and fs: ext4 with start 4096s and end 100%
Thu Jan 1 00:01:23 1970 Calling fmtpart for partition /dev/sda1 and fstype ext4
Thu Jan 1 00:01:23 1970
Thu Jan 1 00:01:23 1970 Mounting root
Thu Jan 1 00:01:23 1970 Trying to mount to MNT_ROOT (/mnt/root)
Thu Jan 1 00:01:23 1970 Using device->root: /dev/sda1
Thu Jan 1 00:01:23 1970 Error occured trying to mount root of /dev/sda1
Thu Jan 1 00:01:23 1970 Halting Install. Error message was: can’t mount root

I tried this several times with the same result. I also tried to install OSMC with Noobs but then it doesn’t give me the opportunity to install the system on my USB stick.

Any idea of what’s happening ?

Many thanks to the ones who can help me !

I assume you bought a harddisk not a USB stick, or?

No need to format the drive as the OSMC installation will create a single parition when you run it.

OSMC will currently format USB drives and use msdos not gpt
This is probably causing problems.

The OSMC installer is not designed to format a disk bigger than 2TB. You will find it easier to install to SD card and just use the HDD for media. Take regular backups of the SD card and store them on the HDD.

If you get a quality SD card, it should last you a year or more. One of mine is over 2 years old and still working fine. However, they are just used for the OS, all media is on spinning drives.

On the other hand, some people in here worry about their spinning discs staying on all the time. If you put the OS on the spinning disc it will probably stay spinning all the time.


Thanks a lot for your quick answers.

@fzinken yes you’re right I meant a HDD
@all : I understand that it might not be possible to install OSMC on my 4T HDD. I’ll do as you suggest and install on my SD card (already tried it and it worked). I suppose I will be able then to format my HDD from OSMC !?

Thanks again.
Wish you all a very happy new year !



Last question : better format my HDD in ext4, NTFS or both with 2 partitions? (we all have windows machines at home)

If you permanently connect it to OSMC than etx4 is the choice.

You can share the content of the drive to those machines via Samba
While originally you wrote you wanted to install nextcloud anyhow.

Thanks !!

OSMC doesn’t have a format function in the GUI. You will still need to partition the disc as GPT as you did at first.