Failing with MariaDB on Synology and Vero4k+

I can not get the hang on using an external db for osmc.

I tried to follow mostly this, but there is no new DBs getting created in Maria

and later from here

I also tried removing the hashtag that the first instruction told me to add, #bind-address =
And finally I tried with port 3307 in advancedsettings and with both port 3306 and 3307 in the My OSMC menu.
No luck.
For a long time there didn’t show up anything in Maria.
Finally at some point databases was added, but as far as I can tell there is no info in them.


ERROR: Unable to open database: MyVideos99 [2005](Unknown MySQL server host '' is not a valid ip address. Not sure if ! in password is an issue.

Typo that only got in there the latest try.
And switched password without helping

New logs

And logs for port 3306 if that helps

ERROR: Unable to open database: MyVideos116 [1045](Access denied for user 'kodi'@'Neonlicht.lan' (using password: YES))

make sure you granted privileges to your user in the db.

ERROR: Unable to open database: MyVideos116 [2003](Can't connect to MySQL server on '' (111 "Connection refused"))

It does not as your db is on 3307.

Much confusion about the ports in the guides online. But great that you could help me with that.
So. Database user kodi (which has complete privileges) fails to login?
How do I proceed? Can I check with ssh somehow how to log in?
Is the problem with mariaDB and synology or with osmc configuration?

With you using port 3307, you are getting Access Denied, so you are able to talk to the MariaDB.

With port 3306 you are getting Connection Refused, so that tells us that Maria is indeed using port 3307.

So now you just need to check the MariaDB permissions for the Kodi user. Maria user permissions can be set so that a user can only connected to the database from a specific IP, range of IPs, or all IPs. If you don’t have port 3307 forwarded, then I’d just allow the kodi user to connect from any IP.

If you want to check from ssh, you need to install the maria client:

sudo apt install mariadb-client

You can then try to connect:

mysql -h -P3307 -ukodi -p

(That’s not a typo the command is mysql, not maria)

ok, apt seem to not be a command on synology…

But I think i found one problem. I had only created the user kodi in mariadb, not in synology.
now this command works and gives correct results:

./mysql --host= --protocol=tcp --port=3307 -u kodi -p

(the !! are back in the password because synology wont accept passwords without special signs, but I see no reason that should be the problem)

But I still dont get a database when I restart the vero4k+
It is however creating/recreating the MyVideos116 database with the current settings, but empty

latest logs:

That was supposed to be run on OSMC.

1 Like

Well there are no errors in your logs. Did you tried to scrape some videos into the database?

1 Like

You beat me to it…

ah, thank you.
Since all my sources was still there I didn’t realize I had to go and set content type again.