Failure of Automatic Update (RPi 2)

I’m running OSMC on RPi 2. I have KODI installed. The system works but with some functional hiccups I need to resolve.

Each evening the system attempts auto update. Each time it fails. I did not find any hints in /var.log or in kodi.log. (I have posted the kodi.log )

The support person at kodi suggested I inquire with you folks.

I’d appreciate any tips or suggestions.
Tom Stephenson

Please use log uploader in MyOSMC settings addon to provide all logs.

Sounds like a problem I am having:

Could be, but that isnt indicated in the log.

The log shows Exceptions to do with the communication between MyOSMC and the Update Service. Possibly because the update service is inactive?

There are other Exceptions relating to, which is also having socket (communication) issues. Possibly THAT is causing the error?

I am looking at the other Update issue and should hopefully have a resolution soon.

I do see notifications on a frequent basis that kodi cannot connect to server
(There are error messages to that effect in the kodi.log)

I too think the connection issue is part of the issue.
I thought about setting the IP address for static IP but my router has been set with a locked in reservation so I see no reason for negotiation between the router and the RPi.

I did do a manual update (the system said it was updated but I didn’t see any new items). A reboot after the manual update still tried to do an automatic update (which failed).

The discussion on whether or not two programs are hogging the network caused me to think. I have backup set for each night (0:00:00). Might be that backup is captured the NIC during auto update. Think it does that at boot time as well. I changed the backup time to 02:00:00 but maybe I’ll just disable it for tonight and see what happens.

Tom Stephenson

One more thing. I looked for an add-on that would support MyOSMC logs. Did not find such an animal.

Tried running the add-on OSMC settings but the script does nothing. How about a hint?

Tom S

It’s not a separate add-on, but a component of “myOSMC”:

But the above screen doesn’t come up. When I click on “OSMC Settings” nothing happens.

If he’s not using the OSMC skin, then it will be OSMC Settings addon found under programs.

OK, a few more steps. I changed the skin to OSMC and made sure the setting was to display at boot time. Also disabled backup to prevent any conflct for the NIC.

At boot time the OSMC menu did NOT come up. Rather an NON-SMILEY icon came up. Then it went away. I got the message about not being able to connect to the server. The notification went away and the standard OSMC skin came on.

I am thinking I have big pieces of OS missing from this machine. Why is the NIC going off line? Or is it really?

Think I will write a little shell script to ping a known address (like my router) every ten seconds to see if the NIC ever fails.

Tom S

Is MyOSMC disabled?

Sorry - got it wrong, so deleted the entry

OK, I ran some tests last night on the basic functionality of the NIC. For the first few hours ran two pings against the router every 10 seconds. (script would declare failure if no response in 2 attempts. During this test I did have video streaming. Did see the unable to connect message while this test was running but the ping test did not see any disconnect at the NIC.

Stepped up the test for an hour - While pinging the router from the RPi and streaming video I flooded the NIC with pings from my laptop. Same result as previous test.

I looked carefully at the timing of the ping responses. Prior to the flood test most pings were between .5 and .6 seconds. During the flood test most pings were .6 or .7 sec but on occasion were 1.5 to 1.7 sec.

At no time did the NIC fail even though system reported 'could not connect to the server ’

Tom Stephenson

You have a couple of issues here - one seems to be network connectivity, the other is addon related.

Via SSH are you able to ping websites by IP address ? Are you able to use wget to download a file from a website at a reasonable speed ?

Your second problem is that the OSMC settings service is not starting up - which is preventing you from launching the OSMC settings addon. This can be caused by another addon malfunctioning.

You have a lot of 3rd party addons installed - any of which could be causing your problem. I would try disabling some of the addons you have installed, particularly which seems to be crashing frequently.

I very much doubt that you would be seeing these problems on a fresh install of Kodi that does not have all these addons installed.

One other thing worth trying is to run an update to get yourself fully up to date as we have fixed a few bugs in the OSMC settings addon and also disabled ipv6 by default - it’s possible that your connectivity problems are a result of some sites advertising ipv6 addresses which your OSMC box cannot reach.

Because you can’t run OSMC settings to do the update you can do a full update like this:

sudo apt-get update && sudo apt-get dist-upgrade

Another way to do it is to boot with CTRL and SHIFT keys held down until you see the blue update screen.