FATAL ERROR: Coupld not find root filesystem device /dev/vero-nand/root

My Vero 2 randomly fails to boot with this message:

Waiting for root filesystem device /dev/vero-nand/root
FATAL ERROR: Could not find root filesystem device /dev/vero-nand/root - if this is a USB install please check the USB drive is connected.

Then it dumps me into the OSMC initramfs Rescue Console.

I have used the osmc-installer (Windows version) to create an install SD card (OSMC_TGT_vero2_20160518.img.gz), changed to “recovery.img” and re-installed the system several times.

After a fresh install, I install the latest update, then I customize a few settings (like defaulting to the Confluence skin, changing the SMB client workgroup name, turning off services I do not use like AirPlay, etc.), then reboot, then customize a few more, then reboot. There does not seem to be any discernible pattern to the failure. Once it fails to boot, it will not boot until a re-install. One time it failed to boot after installing & configuring the Yahoo Weather addon, once after adding the ESPN3 addon, other times one or both of those same addons installs fine. Sometimes it fails to boot with no addons.

As for connections: A gigabit Ethernet cable providing a statically reserved DHCP address; an HDMI cable sometimes connected to a Samsung TV, other times to a Denon AVR; the included power adapter; the included USB remote receiver in the USB port next to the SD card slot; and a USB keyboard in the USB port farthest away from the the SD card slot (but on the same side).

As for logs, am I able to get to them from the recovery console? When I enter “grab-logs” I get “grab-logs: not found”

What else can I provide to help you help me?

This sounds like filesystem corruption.

  • Can you check whether you are using the official power supply?
  • Can you try running the system without any add-ons for 24 hours or so and let us know if you still experience problems?

Which add-ons are you installing? You can try installing one at a time, leaving it 24 hours / rebooting etc to rule out a problem with any of them.

As a side – you should put the USB receiver in the rear port, although that’s not the cause of the issue reported above.

Sam

Yes, included/official power supply.

Over the last week or so, I have had the failure at least once without any addons installed. If you think it will help, I can try again. Addons I’d like to use (in order of importance to me) include VideoExtras, ESPN3 (those two are pretty much mandatory, the rest I can easily live without), HDHomeRun, Yahoo Weather, CBSN News, and CBSnews.com.

I’ll move the USB receiver now.

Do you have another 5V, 2A power supply lying around?

Sam

Yes, I have a 5V 2A power supply from a D-Link switch.

The Vero2 has is has been stable for 24 hrs, with all of the interface setting changes applied, but with no addons. I just powered it off to check the power supply and match to an alternate. Do you want me to power back on with the alternate power supply, or the official?

Once (if) the device comes up, should I then try installing an addon? If so, any particular addon?

If the V2 has been stable for 24 hours, and this has been hard to achieve before, this may suggest a problematic add-on. You could try installing add-ons one by one until you find the culprit.

If the D-Link is 5V 2A, it won’t hurt to try that either.

Sam

Well, I had the Yahoo Weather addon installed for almost 2 days, multiple reboots & power off/power on cycles, no issues. Today I installed the ESPN3 addon, watched a video clip then rebooted 2 or 3 times, then on the 4th reboot I get the error message above. The ESPN3 addon works fine on all of my other Kodi devices (Windows 7 Intel NUC PC, Ubuntu 14.4 Intel NUC PC, old generic Core2Duo box running XBMCBuntu, Nexus 6 android phone, Samsung TabPro 12 android tablet, and NVIDIA SHIELD).

I have also had this happen without the ESPN3 addon installed at all, so I’m not convinced that THIS addon is the problem. It seems addons in general cause problems (at least for me on this particular box).

Just to confirm: did you swap over the power supply yet?

Do you know when you got the Vero? Is this a new issue, or has this always been an issue.

Cheers

Sam

No, still using the stock power supply–I did not want to change too many variables at one time. I just reloaded the OS using the D-Link power supply, applied the latest update, and it would not boot at all after the update restart. Blue light on, HDMI display saying no signal. Removed power, reinserted multiple times, same result. I switched back to the stock power supply and it booted fine. I re-double-checked…the D-Link power supply says 5V, 2.0A output.

I don’t remember when the Vero arrived, over a month ago. I initially powered it up and checked it out, but it has just been very recently that I found the time to try to configure and use it as intended.

So now I am again reinstalled, updated to the latest version, interface customizations applied. What do you want me to try next? Different addons this time?

Hi

This may suggest that the D-Link power supply isn’t putting out enough output (just because it says 5V 2A doesn’t mean it’s true) and that the OSMC power supply may be defective.

Some logs when you next get the issue (see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/) may be useful
Sam

If my issue is that the device will not boot, and I get dumped into the recovery console, how do I get the logs? Is there a tutorial specifically for this scenario?

Sam

This issue has plagued me consistently. Over the last year since I first asked for help I’ve had to reload OSMC on the Vero 2 a dozen or more times. A few days ago the device said that an OSMC update was available, so I tried to click OK on the remote but there was no response. This time, rather than power cycling the Vero 2, I SSH’d in and issued the reboot command. And once again it halts with the error “FATAL ERROR: Could not find root filesystem device /dev/vero-nand/root - if this is a USB install please check the USB drive is connected.”

Above you asked for logs, I then asked how to get logs from a device that will not boot, then radio silence. What can we do to resolve this issue once and for all?

Hello

The last post I read seemed to suggest that the device was in a usable state again. I’m sorry to hear you are still experiencing problems.

Please perform a reinstallation of OSMC with the latest version; then post logs. I’ll then see if there are any obvious issues

Cheers

Sam

Reinstalled with the latest version: OSMC_TGT_vero2_20170705.img.gz.

Logs:
https://paste.osmc.tv/wikazaciwu

Hi,

Unfortunately, the logs show you might have faulty NAND, which would explain why you sometimes have issues with your device after a reboot.

If the device is still under warranty then we can replace this for you with a new unit. Please contact sales@osmc.tv for further information

Sam