Fatal Error Putty


I am just trying to setup my OSMC to connect to my new NAS box and want to use autofs. Following the instructions to access the command line, I have just tried to connect using Putty and am receiving a fatal error message “Network error. Connection refused.”

I can’t find anything on the forums or on Google to help me. I do have pihole installed on my network and both my PC and OSMC are using pihole as the DNS server. I have disabled blocking on pihole to see if this would prevent but I am still getting the error.

Please can someone help?


Because you didn’t mention, I’ll ask. Have you actually installed SSH server on your OSMC box? I don’t believe it’s there by default. You need to go to MyOSMC and then look in the store area. I’m pretty sure there is an option there to install the SSH server.

1 Like

Good point, I have checked and it was installed. I think I have logged on before and setup autofs but it was a long time ago now.


There could be an issue with the SSH server, could you please provide logs. You’ll need to upload them via MyOSMC, more details below:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Regards Tom.

Followed your instructions and I have been trying for a while now to upload the log files but I keep getting a message “could not retrieve URL. Copy Logs to SD card instead?”

When I select Yes, nothing seems to happen. So I have copied the logs manually to the SD card and I get message to say “Copy successful” but when I look at the SD card, there are no logs. The SD Card is formatted as exFAT, would that be an issue?

I have changed the network settings to bypass pihole completely, rebooted a number of times now.


How is your vero4k/4k+ connected to your network? wired or wifi.

Have you checked in myosmc that the vero has an IP?

Regards Tom.

Yes, it is connected and it is using the wired option. I can ping the IP Address from my windows computer.

But is also the netmask, DNS and Gateway correct?
There must be something stopping your Vero to communicate with the Log Server

I have changed the network configuration to bypass my pihole, which also acts as DHCP and DNS.

It is manually configured with the DNS servers given to me by my ISP. Netmask and gateway are correct. I will try to use some other DNS servers to see if that helps.

DNS would only be important for the log upload.
If you still have an issue with connecting from Windows we also can do other checks:

  1. Post a picture of the MyOSMC Network screen
  2. Post what your Windows Machine shows for ipconfig and route
  3. From windows machine ping the Vero then on windows run arp -a and post that
1 Like

Thank you all for your suggestions and help. I changed the DNS servers to the Google ones ( and and the log files uploaded but not only that, I can now access Vero using Putty!!

Who knew the DNS servers would cause these issues? Thanks again for your help.

I may need to ask for help with autofs and NFS shares as I have never used them before and they are not working but I will start another thread if needed.


It shouldn’t. Was pihole also providing dhcp?

Can you please provide the link? It may help us see what the issue was.

Regards Tom.

Yes, pihole was providing DHCP but I think I stopped using DHCP and just used manual IP address with DNS servers set to and before changing it to the Google ones.

Here is the url: https://paste.osmc.tv/uzujeqoqes


I can’t see any reason why & would cause ssh and logs not uploading. They are valid DNS servers. I can only guess subnet or gw were also incorrect as well.

Regards Tom.

It is very strange, I have not changed anything and now I can’t SSH onto Vero anymore, can’t upload any logs either.

All I want to do is be able to watch movies on my new QNAP box as my old one died, but I am really struggling to get it to work.

Hopefully it is something simple I am doing wrong that someone can see :pray:


Is outside of the DCHP range provided by pihole?

Regards Tom.

No, is inside the range. Let me change it to see if it helps.

1 Like