Faulty Remote?

Hi. I think I have a faulty remote control for my Vero 4K. The OK button and the cursor buttons work but no other button does anything. I tried unplugging the Vero and also changing the battery. I tried pairing but pressing Home and OK for 5 seconds doesn’t give a flashing light. If I press the other buttons The blue led does flash.

Is the remote faulty?

Thanks for the help.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I had to use my Logitech Harmony remote to navigate. Only the cursor keys and OK button work on the Vero remote.

The kodi remote app on my iPhone works fine as well.


Will check this shortly.

One other thing I forgot to mention. I tried the key map add on and the keys didn’t seem to register when I pressed them.

@sam_nazarko @Tom_Doyle Any luck reviewing the logs? Thanks


Looks like you need a new dongle.
Ping support@osmc.tv with your order number and we will ship you a replacement.



Thanks. I have done this.

1 Like