February update change overscan?

I had been using Jarvis with very simple settings … overscan disabled in the config.txt, and the GUI calibrated to compensate for overscan.

This resulted in the video being playable (overscan resizing can seriously degrade playback performance on some videos) but it also meant that when I wasn’t playing video, the GUI was usable.

Recently I noticed that with the same settings, any video I play is now showing the full (non-clipped) GUI, for example, when paused. Now, this looks great, but it suggests overscan resizing is being used. And I’m getting video tearing and audio dropouts that I didn’t used to get.

During playback, when I press the right joystick (thanks, Krypton!) I get a message showing me that if the video is not in the desired resolution, it is being resized during playback, which is necessary, but it’s being resized according to my calibration settings. It’s not clear to me whether the performance hit is due to the resize alone (seems unlikely…), or due to the inclusion of my calibration settings in the resize.

Did you attempt to change the aspect ratio or wide screen settings on your TV?

My TV doesn’t have much in the way of options… it’s got

  • Full (normal)
  • Zoom (presumably for 16:9 rebroadcast on 4:3 channels)
  • Wide Zoom (presumably for anamorphic 16:9 on a 4:3 channel)

I did a lot of testing finding what worked and what didn’t

Here are input file resolutions and rates that produced a perfect 1920 x 1080 (or at least something x 1080) picture at 59.94 Hz (unfortunately, I haven’t kept the files…)

The key thing appears to be that they are very close to being an integer fps, but not exactly.

  • 400x228 @ 29.97 fps
  • 426x240 @ 29.97 fps
  • 480x270 @ 29.97 fps
  • 640x360 @ 29.97 fps
  • 640x480 @ 23.97 fps
  • 854x480 @ 29.97 fps
  • 640x640 @ 29.97 fps
  • 640x820 @ 29.97 fps
  • 1280x720 @ 29.97 fps
  • 1280x720 @ 59.94 fps
  • 1920x1080 @ 23.976 fps
  • 1920x1080 @ 29.97 fps

And the following files produced 1026 lines (based on my GUI calibration overscan), at 60 Hz, but oddly not always getting them exactly right… OR I couldn’t read the number properly due to scaling.

Most of these are integer fps, but one is non-integer… .but it’s also further from an integer than any of the ones that maintained the 1920x1080 output size in the above group.

  • 640x360 @ 30 fps
  • 638x360 @ 24.83 fps ← the only non-integer to get scaled
  • 854x478 @ 30 fps ← should have had 1026 lines, had 1022
  • 852x480 @ 30 fps ← should have had 1026 lines, had 1028
  • 1136x640 @ 24 fps
  • 360x642 @ 30 fps
  • 720x720 @ 30 fps
  • 1280x720 @ 25 fps
  • 608x1080 @ 24 fps
  • 1920x1080 @ 25 fps ← this one has the tearing & audio drop out, even at low bit rates… unfortunately there are a LOT of files with these charteristics

When I press the right joystick as a button, it tells me what video mode Kodi is using, it’s always NORMAL, although other options are available similar to what’s on my TV. I’m not aware of a way to access this feature without the gamepad.

My System Display settings are for DESKTOP resolution at 60 Hz.

My config.txt settings include


This is the preferred setting (1080p 60Hz) according to tvservice.