February Update HDMI issues on pi2 on Samsung TV

Just installed February 21 release of Kodi 16.0 - and spotted a number of issues (using pi2 and Samsung HDTV)

  • Samsung remote no longer working (CEC Adapter 3.0.1) - althoug TV says it can see the Anynet+ device
  • Post update screen resolution set to desktop (very poor) - have to set to 1980x1080p by hand - also happens if I reboot manually.
  • Whenever I play a movie or video stream the HDMI input switches to another device (have to manually select source to get back to OSMC and it then works fine)

All was working fine before the update.

Has anything changed in the HDMI/CEC support with this release?

Thanks

A post was split to a new topic: No ssh, no ping after update

Not sure why this post was split to include the ssh/kore remote post…

The Kore Android remote continues to work fine for me in the upgraded system - but the HDMI CEC remote (Samsung TV remote) no longer works.

I tried installing a fresh install on a new SD card of the February release but hit the “hang on licence page” issue so gave up for now.

Download and install a fresh image. That issue was resolved several days ago.

I think am seeing a similar problem on my Panasonic plasma since that Feb 21 update.

The issue is because ‘hdmi_force_hotplug=1’ now automatically creates ‘hdmi_edid_file=1’ in /boot/config.txt when you go in to Pi Config settings which doesn’t work for me. Even if I have a valid /boot/edid.dat file, getting CEC to work seems to be completely random and most of the time is completely broken when I next try and use the TV.

If you uncheck ‘store_hdmi_to_file’ in Pi Config, then ‘hdmi_force_hotplug=1’ is deleted in /boot/config.txt.

Effectively, it is no longer possible just to have ‘hdmi_force_hotplug=1’ in /boot/config.txt.

Unfortunately, I started a new thread earlier ‘HDMI CEC Config.txt no longer working properly’ as my search didn’t pull up you post.

CEC issues after upgrades might be resolved if you power down (disconnect the power line for a minute) all devices connect to HDMI and then power them on again.

If you manually edit config.txt the changes will persist as long as you don’t open MyOSMC, hopefully this will be fixed soon

ATTN @Karnage

1 Like

I was told that ‘hdmi_force_hotplug=1’ must go with ‘hdmi_edid_file=1’, which is why they are tied in the Pi Config module.

@popcornmix should these be separated, or is this a marginal case?

hdmi_edid needs force hotplug but force hotplug doesn’t need hdmi_edid, hope this makes sense

1 Like

All HDMI problems solved with fresh installation of latest OSMC release 2012-0-03 release…

Thanks for all the responses…