Ffmpeg not building on vero 4k

Apologies if this info is around somewhere but im really struggling to install ffmpeg for my vero 4k.

have tried to install from apt-get and from adding sources to /etc/apt/sources.list but always run into various errors.

what is the correct way of installing ffmpeg for osmc with a vero 4k? only guides I’ve found relat to the RPi2 and wont build.

E: Package 'ffmpeg' has no installation candidate

can anyone help?

Followed this: [HowTo] Autoedit – Fully automated DVR with commercial detection
but its aimed at RPi2 not vero.

Hi Hamish,

if you just skip the part about the RPi’s hardware decoder, the rest of the instructions should also apply to the Vero.

What you will not get without further support from @sam_nazarko is de- and encoding in hardware as this is not part of the standard ffmpeg. So don’t expect video processing in real time.

libav is included in Debian rather than ffmpeg. Not sure if this is of any use to you

Sam

@fretzke thanks and yes I tried that but ffmpeg wouldn’t compile, was getting some odd errors which I can post later.

I guess hardware support is what I need as I’m trying to get it to work with Tvheadend and IPTV streams so libav won’t work for me unfortunately.

Basically following this concept

http://www.matthuisman.nz/2017/06/libreelec-tvheadend-iptv-freeview-nz.html?m=1

There’s am-ffmpeg which may be able to be used as a drop in replacement to achieve this.

thanks @sam_nazarko - i dont know enough osmc and building from source to know whats going wrong, but i cloned the git repo and tried a ./configure and make and got the following:

git clone git://github.com/osmc/libamcodec/
cd libamcodec/
/sources/libamcodec/amffmpeg$ ./configure
libavutil/avconfig.h is unchanged

WARNING: unknown architecture aarch64
osmc@osmcmoneykings:~/sources/libamcodec/amffmpeg$ make
libavcodec/Makefile:695: /home/osmc/sources/libamcodec/amffmpeg/libavcodec/aarch64/Makefile: No such file or     directory
make: *** No rule to make target '/home/osmc/sources/libamcodec/amffmpeg/libavcodec/aarch64/Makefile'.  Stop.    

Any guidance here would be very helpful :slight_smile:

Try setarch linux32

@dillthedog i tried

$setarch ./configure
$make


In file included from libavformat/CacheHttp.c:26:0:

libavformat/internal.h:26:27: fatal error: amconfigutils.h: No such file or directory
#include "amconfigutils.h"

compilation terminated.
common.mak:31: recipe for target 'libavformat/CacheHttp.o' failed    
make: *** [libavformat/CacheHttp.o] Error 1

You need to tell it where to look for the header file it can’t find. Better to download this which has everything,

Normally it would be something like ./configure CFLAGS="-I/path/to/header/include" but these guys have different ideas! So it looks like:

./configure --extra-cflags="-I/path/to/header/include"

and then run make -j4 to use all four cores.

Edit: If you clone the whole thing, the missing header is under amavutils/include.
Edit 2 : Maybe I’ve jumped the gun a bit. I see that you cloned some source code from OSMC. Nevertheless, the missing headers are in the location I linked to.

Thanks for the help @dillthedog, i managed to clear out other attempts and build from source using this guide

https://owenashurst.com/?p=242

now onto configuring tvheadend!

thanks guys

Are you sure you have the hardware acceleration that you need?

On the Pi it uses the openmax (omx) encoder, but that’s most likely incompatible with the AMLogic hardware of the 4K. There’s no reference to openmax or omx on the page you linked to, so I’m guessing everything will be running in the CPU.

Yes, please do post or pm them. Best would be a full log including the commands you used, so I can adjust the instruction page.

Having watched this I don’t see where you would need ffmpeg at all. If you just stick to the walk through, the recording profile is all default which means, no de- or encoding whatsoever. When you record a stream, the data is simply passed to disk, when you watch live or recorded TV, the decoding is all handled by Kodi.

ffmpeg only comes into play if you try things like I described in the tutorial. A nice toy – at least for me – but far from necessary.

Hi,
I’ve a question: can i use my vero 4K to convert h264 in hevc? With ffmpeg i can convert from command line, but the hardware? Is it possible? Thanks

Not at this time. I’m not sure there’s a lot of demand for it. You would likely get better results on a PC

I am trying to follow this but can’t seem to compile. At the very end I ran make install and it failed trying to find a header. Can we get a How-To on how to install amffmpeg on a Vero 4K/4K+?

As noted in the previous post,

Not at this time. I’m not sure there’s a lot of demand for it.

That was from 3 years ago, so nothing has changed and there seems to have been no demand for it.

The ffmpeg version it’s based on is so old I’m not sure if it’s of any use

Ok. Is there a new ffmpeg version I should use? I am wanting to get ffmpeg for

Being new to linux I am not sure how to compile my own software based on the hardware I have.

You can just build ffmpeg then but unfortunately there won’t be hardware acceleration.

Remove the —enable options for pi like MMAL, VC1 etc