Ffmpeg on rbp4 with osmc and kodi 20.2

I am not sure how this happend but I had ffmpeg working normally on my Raspberry PI 4 with OSMC and for some reason it stopped working saying that libGL.so.1 is missing. I understand that this lib is provided by libgl1 package however this I cannot install since it is conflicting with rbp2-mesa-osmc.

How can I have ffmpeg running on my system?

Alternatively, can I uninstall rbp2* and rbp4* packages install libGL1 and thern reinstall rbp* stuff?


That’s because we were accidentally providing libglapi-mesa in OSMC, when we shouldn’t have been doing so as we provide our own implementation downstream.

This should solve it for you:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb http://apt.osmc.tv bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Now run:

sudo apt-get install libglapi-mesa

You may also need to reinstall ffmpeg.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

For context, see

Version 2023.08-1 Update Broke mpv · Issue #743 · osmc/osmc · GitHub.



Guessing from the fact that you marked it as a solution that this worked for you @rostok

Are you compiling ffmpeg yourself? The version from Debian upstream probably won’t have hardware acceleration for Raspberry Pi.


Thank you. It solved my problems and I got ffmpeg running. I am astonished how quickly you responded.

Regarding compiling ffmpeg - after failing to solve my issues with installing various packages and looking for missing libs I did tried to compile it. I started with libraries but it took so long I thought why not give the osmc forums a chance. Your response was so fast I didn’t even manage to face any problems with compilation. Thanks again!

Glad to hear this.

You’re welcome.