"File exist" error while adding a SMB share


#1

Hi all,
this evening made a clean fresh installation of Kodi 17.6 on a Raspberry PI 3 with NOOB downloaded from official website.

While adding my “video” SMB share, actually shared by a Synology NAS, I always get a “File exists” error without any detailed information about.

The procedure followed to add the share is:
“Video” - “Files” - “Add videos…” - “Browse” - “Add network location…” and the filling all the share informations; after confirmation I get the “File exists” error. My SMB share is password protected and there is no way to declare a public non password protected share.

Any clue is apreciated. This procedure has worked for the past installations of Kodi and share is reachable by the other machines (PC and MAC) I have.

Googling around I’ve seen it’s a very commons issue but I cannot undertand how it was finally solved by other peoples.

Thank for help.


#2

This could be a samba called “bug smbc_opendir should not return EEXIST with invalid login credentials”
By filling in all the share information like you said do you also include username and password?
Your path should look something like smb://myusername:supersecretpassword@synolgy/share


#3

Yes – that’s the problem. Currently we don’t build Samba downstream unfortunately.


#4

Thank you for the info.
You pointed me in the right direction; the credentials on NAS were not setup correctly and Kodi couldn’t get access on the share.

Now everything works fine.


#5

I lost one night trying to figure out what the problem was: I think that rising the correct diagnostics is the basic of a product, so, please, fix this nasty bug!!!


#6

This is not a bug. You stated yourself the nas was not properly configured. Kodi provides logging that likely may have pointed toward the issue but you failed to provide them. Lastly, this is more specifically a Kodi issue. Any installation of Kodi on any platform would have behaved exactly the same, not just OSMC. If you think something should be changed in this regard then you should be addressing Kodi developers.

Good luck and glad you found the problem.

EDIT: Even better, the error seems to be the fault of your smb server on your nas it would seem, so neither a Kodi nor an OSMC issue.
https://forum.kodi.tv/showthread.php?tid=330123&pid=2718656#pid2718656


#7

He’s right that it’s a bug. Unfortunately it’s not an OSMC bug.

If we packaged samba downstream we could address this correctly. It’s likely that we will in the near future


#8

Not wishing to hijack this thread, but I’ve received this “File Exist” message when trying to add a second shared folder (second USB drive) from the same W10 PC.

The first share works fine, and I can see the movies from this share. The second share on the same W10 PC has TVShows.

When I try to add this source I get the “File Exisits” error message. I’ve been searching for a fix, but I’m not sure what to try next.

Thanks