"File Exists" error


#1

After a fresh reinstall, as detailed in this thread, I restored from backup, and now I get a “File Exists” error whenever I connect to some (not all) of my network shares.

Logs available at https://paste.osmc.tv/ojoyumoyac


#2

You’ve added in fstab:
//chance.quarteredcircle.net/visual\040arts /Chance/Visual\040Arts cifs rw,credentials=/root/.smbcredentials,uid=1000,iocharset=utf8,sec=ntlmssp 0 0

So why are you using Kodi smb as indicated below?

<source>
            <name>Movies</name>
            <path pathversion="1">smb://CHANCE/visual arts/Movies/</path>
            <allowsharing>true</allowsharing>
        </source>
        <source>
            <name>Television</name>
            <path pathversion="1">smb://Chance/Visual Arts/Television/</path>
            <thumbnail pathversion="1">/home/buggles/xbmc_dir/userdata/Wallpapers/Buggles.png</thumbnail>
            <allowsharing>true</allowsharing>
        </source>
        <source>
            <name>Music Videos</name>
            <path pathversion="1">smb://CHANCE/visual arts/Music Videos/</path>
            <allowsharing>true</allowsharing>
        </source>

You should be adding these locations into Kodi from their mountpoints that you have created. That’s the whole purpose of the fstab mounts.


#3

That was me trying to work around the problem. That also didn’t work:

osmc@Oswin:/Chance/Visual Arts$ sudo mount -v /Chance/Visual\ Arts/
Credential formatted incorrectly: (null)
mount.cifs kernel mount options: ip=192.168.23.5,unc=\\chance.quarteredcircle.net\visual arts,iocharset=utf8,sec=ntlmssp,uid=1000,user=boxxy,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

It’s the same credentials that mount the others, and the directory on Chance has the same permissions.


#4

Hi,

If you not using fstab mounts, then I suggest try changing the smb max protocal to v1 or v3. You can find this under under settings, services, smbclient.

But I would recommend persevering with fstab mounts, this guide should help:

Thanks Tom.


#5

It is set for v3.


#6

Hi,

Then for testing try v1?

Or better yet continue with setting up the fstab mounts.

Thanks Tom.


#7

I tried v1, and when I went to a share it asked for the ID/password, but wouldn’t accept it.

The fstab mounts mount all of the mounts with the same ID and password except the one that holds all of my movies/TV.

osmc@Oswin:~$ sudo mount -v -a
/Chance/Downloads        : already mounted
/Chance/Books            : already mounted
/Chance/Pictures         : already mounted
/Chance/Music            : already mounted
Credential formatted incorrectly: (null)
mount.cifs kernel mount options: ip=192.168.23.5,unc=\\chance.quarteredcircle.net\visual arts,iocharset=utf8,sec=ntlmssp,uid=1000,user=boxxy,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

#8

Hi,

//chance.quarteredcircle.net/visual\040arts /Chance/Visual\040Arts cifs rw,credentials=/root/.smbcredentials,uid=1000,iocharset=utf8,sec=ntlmssp 0 0

Is visual arts shared with the same permissions as the others? The server is denying the request.

Thanks Tom.


#9

I double checked, yes. The Music directory that loads actually has less rights than the Visual Arts directory.

[visual arts]
        path = /Big_Chance/Visual Arts
        valid users = @users
        guest ok = yes
        read only = no
        inherit acls = yes
        write list = @ntadmin @users root
        comment = Movies, TV, and other video

[music]
        path = /Fat_Chance/Music/
        guest ok = yes
        read only = no
        inherit permissions = yes
        comment = Individual music collections
        write list = @ntadmin @users root
        inherit acls = yes

And the rights:
drwxrwxr-x 6 root users 4.0K Sep 3 20:37 'Visual Arts’
drwxr-xr-x 8 root root 4.0K May 20 2017 Music


#10

Hi,

I would try setting the share permissions the same as the music share.

Also it may help to have ‘Visual Arts’ to be in the root group, rather than users.

Thanks Tom.


#11

Thank you, Tom. Just so I am understanding this correctly, you want me to restrict Visual Arts more, so that the group the user is actually in doesn’t have permission to the share? (IE chown root:root and chmod 755)


#12

Hi,

The folder permissions on the vero2 shouldn’t make any difference, the actaully permissions used come from fstab entry with rw & guid. So the folder permissions on the vero should be left at the default which is root:root.

But I was think more you should try making visual arts like the music share in this way:

[visual arts]
        path = /Big_Chance/Visual Arts
        guest ok = yes
        read only = no
        inherit permissions = yes
        comment = Individual music collections
        write list = @ntadmin @users root
        inherit acls = yes

Also I notice the paths are different Big_Chance & Fat_Chance, is that correct?

Thanks Tom.


#13

Correct.

I did that, restarted smb’s service… and it worked.

I am not sure what changed with that, but… it worked, so I’ll take it. Thanks Tom!


#14

Hi,

Glad to hear its sorted.

Thanks Tom.