File/folder deletion no longer working

As title states, been like this for about one month or maybe longer but only getting around to solving this now. Have to delete files through other means which is a pain so hopefully this is an easy fix.

Doesn’t work in library mode nor file mode either.

Have tried disabling file deletion, restarting, enabling again, but still no joy.

Hope someone can help!


relevant portion of log should be around here

“2019-12-05 18:03:04.401 T:4065517568 ERROR: Delete - Error deleting file /mnt/DLINKM/TV Other/Football/EPL 2019 11 02/video.mkv”

How is the drive formatted?

Have you checked your D-Link devices to make sure you still have the correct permissions set there? I think i’ve seen a few posts from people with a few different kinds of NAS that had permissions change with updates or some other unknown reason.

Now that you mentioned that I do believe there was a fw update around the time this problem started. Should have realised earlier tbh.

Not exactly sure why permissions should be checked but I’ll have a nosey around tmro and see.

DNS 320 uses etx3 file system I believe

Because if the permissions are set only to allow reading the file from your Vero how is Kodi suppose to delete it?

Sorry that should have read “not sure what permissions should be checked”. Damned autocorrect lol. I totally get why.

I’ll have a nosey around though and update again here.

So I’ve had a look around the admin panel and everything looks just fine.

I have two NFS network shares mounted with fstab, would this config have possibly changed somehow?

Otherwise I’m at a loss here :confused:

You could SSH into the Vero, and try to manually create and delete a file.

Do an ls -l on one of the files that you can’t delete would show the permissions.

Your fstab is fine. Any permission restrictions are coming from your NAS.

When you are connected via SSH:

cd /mnt/<name of share>

okay got this

osmc@osmc:/mnt/DLINKM/TVOther/Football/EPL$ rm video.mkv
    rm: remove write-protected regular file 'video.mkv'? y
    rm: cannot remove 'video.mkv': Read-only file system

osmc@osmc:/mnt/DLINKM/TVOther/Football/EPL$ ls -l
total 4955336
-rwxrwxrwx 1 1001 501 5069298914 Nov  3 05:39 video.mkv

That implies that your share is mounted read only. Can you create a file?

touch atestfile.txt

and then

rm atestfile.txt

What’s the output of


seems like you’re correct, but I used it with the existing configuration for many moons and was able to delete just fine.

I have two NFS shares, DLINKM and DLINKZ

any ideas how to proceed?

osmc@osmc:~$ cd /mnt/DLINKM/
osmc@osmc:/mnt/DLINKM$ touch atestfile.txt
touch: cannot touch 'atestfile.txt': Read-only file system
osmc@osmc:/mnt/DLINKM$ mount
devtmpfs on /dev type devtmpfs (rw,relatime,size=774684k,nr_inodes=193671,mode=755)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /run type tmpfs (rw,relatime)
/dev/mapper/vero--nand-root on / type ext4 (rw,relatime,stripe=1024,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/bfqio type cgroup (rw,nosuid,nodev,noexec,relatime,bfqio)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
systemd-1 on /mnt/DLINKZ type autofs (rw,relatime,fd=29,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
sunrpc on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=34,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
systemd-1 on /mnt/DLINKM type autofs (rw,relatime,fd=35,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/mmcblk1p1 on /media/2A58-1302 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0111,dmask=0000,allow_utime=0022,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,errors=remount-ro,uhelper=udisks) on /mnt/DLINKM type nfs (rw,relatime,vers=3,rsize=16384,wsize=16384,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=,mountvers=3,mountport=48446,mountproto=udp,local_lock=none,addr= on /mnt/DLINKZ type nfs (rw,relatime,vers=3,rsize=16384,wsize=16384,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=,mountvers=3,mountport=48446,mountproto=udp,local_lock=none,addr=
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=179844k,mode=700,uid=1000,gid=1000)

It’s mounted read/write, so there is something on the NAS that’s making it read only.

Do both shares do the same thing?

Okay, problem solved!

Now that you confirmed it was definitely my D-link NFS config at fault I went and reset all network shares and modified them to add NFS service. That seems to have done the trick!

For what it’s worth, I think the tickbox for “write” may have been UNticked when I first checked this earlier, so maybe this was caused by the recent fw update. This was the only issue really just a bit odd.

Thank you all for helping with this, much appreciated!