File manager to access from Windows?

Hi everybody,

I am a linux/Raspi newbie. So please be patient with me :smile:
I tried to find out, how many space ist left on my sd card, and wanted to copy files to/from a specific path (/home/osmc/.kodi/userdata/addon_data/screensaver.video/videos) for my screensaver. The reason is, that the video files are rather big and I want to know if a certain file ist too big.

I accessed OSMC with putty from my Windows PC and also with the file manager in OSMC. The first thing I found out is, that this path is not shown. In /home/osmc, I find only the paths Movies, Music, Pictures, TV Shows.
Nevertheless I could acces the path in putty with the cd command. So it exists, and it doesn´t, too.
This is very strange for me, can anybody explain this behavior for me?

Is there any file manager for Windows, which would make it easier for me to do my tasks?
Here I found a screenshot from puk78, that brought me to my idea.

Thank you all! urmel

Basically there is no direct file manager but you could use a graphical SFTP/SCP client like Filezilla

df -h tells you how much space is free

And lastly why you can not “see” .kodi when you just do a ls the reason is that it is “hidden” the “.” infront of it makes it a hidden directory. You could see it with ls -lah

Lastly if you want a more visual filemanager on OSMC itself install mc by sudo apt-get install mc

hello fzinken,

thanks for your explanations!

  1. I started the Filezilla installer from sourceforge, with the result that my Firefox is manipulated by adware. grrrr :rage: Yes I did decline the installation of extra software (in my case an addon named combo). Have to fix this now… sourceforge is not what it used to be…never again.

  2. Could you explain me these results of df -h?

osmc@osmc:~$ df -h
Dateisystem Größe Benutzt Verf. Verw% Eingehängt auf
/dev/root 6,8G 4,0G 2,5G 62% /
devtmpfs 363M 0 363M 0% /dev
tmpfs 367M 0 367M 0% /dev/shm
tmpfs 367M 9,6M 358M 3% /run
tmpfs 5,0M 0 5,0M 0% /run/lock
tmpfs 367M 0 367M 0% /sys/fs/cgroup
/dev/mmcblk0p1 240M 25M 215M 11% /boot
tmpfs 74M 0 74M 0% /run/user/1000
osmc@osmc:~$ ^C
osmc@osmc:~$

I have 8GB SD-Card. Does it mean I have 2,5GB left? What about the other paths?

  1. About mc:

Installation went to this:

osmc@osmc:~$ sudo apt-get install mc

Paketlisten werden gelesen… Fertig

Abhängigkeitsbaum wird aufgebaut.

Statusinformationen werden eingelesen… Fertig

Das folgende Paket wurde automatisch installiert und wird
nicht mehr benötigt:

rbp2-image-4.2.1-1-osmc

Verwenden Sie »apt-get autoremove«, um es zu entfernen.

Die folgenden zusätzlichen Pakete werden installiert:

libgpm2 mc-data

Vorgeschlagene Pakete:

gpm arj bzip2 catdvi
texlive-binaries dbview djvulibre-bin file genisoimage

gv imagemagick links
w3m lynx odt2txt poppler-utils python-boto python-tz

Fortschritt: [ 25%]
[##############…]

Empfohlene Pakete:

perl unzip

Die folgenden NEUEN Pakete werden installiert:

libgpm2 mc mc-data

0 aktualisiert, 3 neu installiert, 0 zu entfernen und 3
nicht aktualisiert.

Es müssen 1.702 kB an Archiven heruntergeladen werden.

Nach dieser Operation werden 6.694 kB Plattenplatz
zusätzlich benutzt.

Möchten Sie fortfahren? [J/n] j

Holen: 1 Index of /debian jessie/main libgpm2
armhf 1.20.4-6.1+b2 [
33,0 kB]

Holen: 2 Index of /debian jessie/main mc-data
all 3:4.8.13-3 [1.212
kB]

Holen: 3 Index of /debian jessie/main mc armhf
3:4.8.13-3 [457 kB]

Es wurden 1.702 kB in 1 s geholt (1.246 kB/s).

Vormals nicht ausgewähltes Paket libgpm2:armhf wird gewählt.

(Lese Datenbank … 28767 Dateien und Verzeichnisse sind
derzeit installiert.)

Vorbereitung zum Entpacken von
…/libgpm2_1.20.4-6.1+b2_armhf.deb …

Entpacken von libgpm2:armhf (1.20.4-6.1+b2) …

Vormals nicht ausgewähltes Paket mc-data wird gewählt.

Vorbereitung zum Entpacken von
…/mc-data_3%3a4.8.13-3_all.deb …]

Entpacken von mc-data (3:4.8.13-3) …

Vormals nicht ausgewähltes Paket mc wird gewählt.

Vorbereitung zum Entpacken von …/mc_3%3a4.8.13-3_armhf.deb

Entpacken von mc (3:4.8.13-3) …

Trigger für mime-support (3.58) werden verarbeitet …

libgpm2:armhf (1.20.4-6.1+b2) wird eingerichtet …

mc-data (3:4.8.13-3) wird eingerichtet …

mc (3:4.8.13-3) wird eingerichtet …

update-alternatives: /usr/bin/mcview wird verwendet, um /usr/bin/view
(view) im automatischen Modus bereitzustellen

update-alternatives: Warnung: Neuinstallation der
Alternative /bin/nano ist erzwungen, weil Linkgruppe editor defekt ist

update-alternatives: Warnung: Erstellung von
/usr/share/man/man1/editor.1.gz wird übersprungen, weil die zugehörige Datei
/usr/share/man/man1/nano.1.gz (der Link-Gruppe editor) nicht existiert

Trigger für libc-bin (2.19-18+deb8u1) werden verarbeitet …

osmc@osmc:~$

And I did´nt find it in “programs” after restart. What went wrong?

Thank you, urmel

You can use WinSCP

Basically your /home/kodi is part of your root “/” which has the size of 6,8G of which 4,0G is used and as you correctly saw 2,5G is free.

Regarding MC we had a misunderstanding. MC is not really a graphical filemanager under kodi but a filemanager that you can use after ssh. So you would not find it under programs in Kodi but you could just start it in SSH by typing mc.
On the otherhand in Kodi you already have a graphical filemanager which you find if you go to settings and then on the right hand site.

Ok, thanks, I got mc to play! Question: Is there a posibility to access my windows PC with mc? So that I can copy a file from PC to Raspi?
The other way: I started the filemanager in Kodi. But how can I tell it to show me the hidden paths?

http://kodi.wiki/view/Settings/Appearance#File_lists

Also, use filemanager to add a new Windows Network source.

Basically yes, but depends how you are sharing the files from your windows PC!
But assuming that you just use the windows share function (SMB) than I would suggest you use Kodi as explained by ActionA to access your Windows Share.
On the other hand for the purpose of OSMC as Media Center I would go down the opposite approach and enable the Samba (SMB) on OSMC which you can find in MyOSMC -> AppStore. After you installed it you could directly access OSMC from your Windows Explorer and copy your file onto it.

Last but not least, if you want to use your OSMC as media center you would in the long run anyhow either need to connect a USB harddisk to the OSMC or mount a network drive to it as the SD card with its 2.5G free would not hold much of your movies.

@dentaku65, ActionA and fzinken,

thanks to everybody!
filemanager works fine, now with the correct settings.
I also enabled SMB on OSMC and can now access it from Windows.

FTP access was´n tested - no need anymore.

Thank you, again, it saves my day :smile:
urmel

No worries, glad to help. Would appreciate if you tag the thread as solved (there is tag button behind the three dots)