File System Inconsistency

Hi everyone!!

I am a big fan of OSMC, and I have been using, configurating and changing it since Raspbmc.

But now I have a problem with my SD card. In other cases using win32 Disk Imager or SD Formatter and installing a backup image I solve it but not now.

It doen’t matter how many changes I do that they are not saved. I tried to format the SD card in Windows with Win32 Disk Imager but it says WRITE PROTECTED, in linux it doesn’t work with gparted… and I tried every single programm but nothing. I also tried with and SD card adapter with the lock and unlock issue but nothing.

This is what it says my RPi when it boots:

I don’t know what to do more.

I will apprecite any advice or clue.


Looks like your card is worn out and may need replacement.

That’s what I was afraid of.

Well at least I have OSMC and the addons installed so I can use the card meanwhile the new SD Card is purchased.

Thank you ActionA, if anyone have any suggestion please let me know.

Your SD card has probably given up the ghost. Especially if it’s old.

Samsung, Sandisk, OSMC or Pi (NOOBS) branded cards are recommended.

The strange thing is that it doesn’t matter what I am doing to the SD Card that the changes don’t save and the SD Card and OSMC work quite properly.

I would try another SD card