Files not showing up in external hard drive help

Ok so first off apologies for any astounding gaps in my knowledge here, I am not the most technologically literate person and have searched around for a solution to this issue with no luck and am posting here as a last resort. So my problem is:

My brother in law gave me a Raspberry Pi in 2016 after showing me how he has used his to make a home media server. Being a pretty serious film nerd I was excited and set up the Pi with OSMC and a 5TB Seagate expansion drive. I then started off filling up my own home media server and over the past 3 or 4 years have acquired ~1400 movies. I would get the movies then transfer them from my Windows laptop to the Seagate, plug the Seagate back into the Pi and this worked great.

Back in January I go to put a handful of movies into the Seagate. I take the Seagate from the Pi, plug it into my laptop, open my folders in Windows explorer, go to drag the movies in and suddenly the Seagate only has 481 movie files showing, basically all the titles starting with # to I. Anything from H to Z has disappeared.

I searched around to see if the files accidentally merged into another folder and they didn’t. I spent two days scanning for deleted files with Disk Drill and didn’t really turn up much useful. Now the weird thing to me is when I plug the Seagate back into the Pi all the missing files are there in OSMC and they play perfectly fine although a handful of them are duplicated. So it seems to me the files are obviously there on the Seagate somewhere I just can’t access them in Windows explorer.

I feel like there must be a problem with the Seagate and every time I plug it into my laptop it mentions that there is an error and I should scan it and fix it and I do but still no files. Obviously there must be some corruption issue going on with the Seagate so this past month I had the time and the extra money to go ahead and buy an 8TB Seagate and I would ideally like to have my whole 1400 movie collection onto it. The idea of starting over getting those films again is pretty painful to me as it took so much time to get them in the first place and it is frustrating because it seems that the files are somewhere on the drive. I tried many of the solutions listed on this website :

and still no luck. I am at the point where I am just going to give up those files for lost and move on but I am hoping before I do so that someone here can help me.

Sorry for the long post and sorry for any lack of clarity or general ignorance. I am happy to answer and questions that anyone has. Thank you in advance for any help that anyone can offer.

Ok, in the long run I suggest to stop this back and forth plugging of the drive as something always can go wrong. I would suggest to keep it connected to the Pi and install the Samba Server from the App Store and just copy the files over the network from you Windows Laptop.

As you wrote that the Movies are visible when you connect the 5TB drive to the Pi I would say you have two options:

  1. Connect the 5TB to the Pi install the Samba Server and then copy the files to the 8TB drive connected to your PC
  2. Connect the 5TB and 8TB drive to the Pi and copy from one to the other.

You can actually do this from within Kodi…

Expect this to take an exceptionally long time, perhaps the better part of a day, if not longer.