Fire TV 4k (Gen 2) remote issues on Pi 3

Hi There… new to the forums and to the Raspberry Pi community. Setup a pi 3 with OSMC running Kodi a few weeks ago. Can go into the “My OSMC” network settings and enable Bluetooth with the built-in Pi 3 bluetooth adapter. Here is the strange thing. I have 2 Amazon Fire TV units at home. An older Gen 1 and newer 4K Gen 2. The Gen 1 remote pairs fine within 30 seconds or so but the Gen 2 does not pair no matter what i do. I tried resetting the Gen 2 remote (back | menu | left arrow) and i tried holding the Home button and the select button for 10 seconds… will not show up under devices what so ever.

Anyone have any info they can share to assist?


Just an update. My gen 2 fire tv remote pairs fine with either of the fire tv units. My iPhone and my harmony hub pair fine with my Pi 3… Still no luck with the gen 2 (4k) remote pairing with the Pi 3 and it’s the one I need paired of course.

Also, I updated OSMC to the latest stable version (November 1).

Thanks for any assistance!