First comparison between Vero 4K and my Intel NUC

After I bought my LG OLED 55C7 tv I also wanted to be able to watch some 4K and HDR movies.
Off course I bought a XBOX One X to not only use to play games but also watch UHD Blu-Ray discs.
Also my current Kodi / LibreElec media player (Intel NUC D34010WYK) will need to be replaced as it cannot play 4K and HDR encoded movies.
As Kodi is just been released as an Alpha version on the XBOX and 4K / HDR mkv cannot yet been played, this is not an option. Also LibreElec cannot yet play 4K / HDr movies on the newest Intel NUC as the latest Intel Linux video drivers are not yet been used in LibreElec. So I was looking for an alternative solution and according to information on the Kodi forum the Vero 4K should be a good solution.

Well here is my first comparison between Vero 4K and my Intel NUC after a few days of setting and configuring the Vero 4K.

The Good:

  • It is a small box. Even smaller than my intel NUC!
  • It plays 4K HDR encoded mkv files without problems on my TV
  • Pre setup of Kodi. So you don’t start with an “empty” box.
  • A lot cheaper than an Intel NUC

The not so good:

  • Less CPU “horsepower” than my Intel NUC, heck even my second Kodi box running on an old AMD E350. I notice this that scrolling of menu’s is less fluent. Also scraping of libraries is my slower.
  • I don’t get good data transfer performance between my files on my Synology NAS the Vero 4K. MKV files of 50 Gbyte the data transfer rate via my network is to slow. (On the same network I can copy files from the Synology NAS to my windows PC with a sustained data transfer rate between 60 and 70 MegaByte/Second). I’m forced to copy the big MKV files to a lokal USB drive before watching the movies…
  • Somehow a lot of my regular full HD (X64) MKV files don’t play on the Vero 4K. After starting a movie it automatically stops after one second. All these files play fine on my windows PC and LibreElec boxes…
  • Only two USB ports. (Yes you can attach a USB Hub to it but it gets messy with all kind of connectors and extenders.) I need one for a USB disk, one for my Logitech Keyboard receiver and if I won’t to connect a USB - Gigabit adapter I need to use a USB hub…
  • More effort needed to configure the Harmony Remote than on my LibreElec box

At the moment I’m not yet fully satisfied with the Vero 4K and the Intel NUC will be the mediaplayer to be used by the rest of the family.

Interesting comparison. Of course less horsepower vs a lot cheaper are the two sides of the same coin. But vero4k punches above its weight playing media. Similarly only 2 USBs vs small box.

On data transfer rate, if you haven’t tried it yet, please try mounting your shares via fstab. Refer to the three recent threads on file sharing in Wiki - OSMC Forums.

On the ‘full HD (X64) MKV files’, could you post media info, please?

Hi Graham thanks for the quick reply.

Here is the media info for one video that Vero 4K fails to play but on other systems it plays well:

Format : Matroska
Format version : Version 4 / Version 2
File size : 10.9 GiB
Duration : 2 h 23 min
Overall bit rate : 10.9 Mb/s
Encoded date : UTC 2018-01-19 06:24:59
Writing application : mkvmerge v19.0.0 (‘Brave Captain’) 64-bit
Writing library : libebml v1.3.5 + libmatroska v1.4.8

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings : CABAC / 4 Ref Frames
Format settings, CABAC : Yes
Format settings, RefFrames : 4 frames
Duration : 2 h 23 min
Bit rate : 9 435 kb/s
Width : 1 920 pixels
Height : 1 040 pixels
Display aspect ratio : 1.85:1
Frame rate mode : Constant
Frame rate : 23.976 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.197
Stream size : 9.42 GiB (86%)
Writing library : x264 core 152 r2851 ba24899
Encoding settings : cabac=1 / ref=4 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-2 / threads=32 / lookahead_threads=5 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=9435 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Language : English
Default : Yes
Forced : No

ID : 2
Format : DTS
Format/Info : Digital Theater Systems
Codec ID : A_DTS
Duration : 2 h 23 min
Bit rate mode : Constant
Bit rate : 1 509 kb/s
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 kHz
Frame rate : 93.750 FPS (512 SPF)
Bit depth : 24 bits
Compression mode : Lossy
Stream size : 1.51 GiB (14%)
Language : English
Default : Yes
Forced : No

ID : 3
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Duration : 2 h 15 min
Bit rate : 52 b/s
Count of elements : 1438
Stream size : 52.1 KiB (0%)
Title : Nederlands UDC4ALL
Language : Dutch
Default : Yes
Forced : Yes

I’ll also try to setup Fstab for Samba.

Question: Do I need to define full directory a share name:
//DISKSTATION/Video2/TV Series
//DISKSTATION/music/audio Surround
etc. etc… (this wil then be a lot!)

Or is it also possible on a higher directory level or even on DISKSTATION level?

Start from the top and try it! Using Win10 as a server just \\SERVER\ works. YMMV.

Thanks for the tip. It work at the first setup (I created 5 links in total). Streaming performance is much better now. I can watch now the big 4K/HDR MKV files without any problems directly from my Synology NAS. :slight_smile:

Tip: See if it is possible to make a small program in OSMC where a user can easily setup their connection with ftsab to their NAS. This will help the adoption rate of Vero.

Which skin are you using? There are some GPU performance improvements that we are working on that may give some improved performance in the near future.

I think you will benefit from using fstab.

Did you try playing them back locally to rule out a network issue?

If you still have problems, a debug log would be useful.

Noted. A Gigabit Ethernet shouldn’t be necessary for any content to be played back however.

This one surprised me. I haven’t used LE before; but I thought our My OSMC → Remotes tool was quite unique. You should be able to match it to a preset remote or transfer your original LIRC configuration as you would on LE.

I am sure we can help you get up and running so that you can recommend the device to your friends and family


Hello Sam,

Thank you for your support it is really appreciated.

Just the regular Estuary skin of Kodi. It is not that it is really sluggish but sometimes I notice a little stutter during the animation of the menu’s (my wife doesn’t see it maybe I’m too picky. :slight_smile: )

I did and it solved this problem including the next one. All these movies now play fine.

Well I managed to set it up to my wishes and is now okay.

So nearly all my “problems” are solved. Just I need to make changes to my Harmony setup so Vero will not be shut down. (Albeit I would have liked it to bring it to a kind of Hibernation mode like my Intel NUC)

For this I would recommend to create an easy setup program for fstab based connections.

Again thanks a lot for your support! It is really appreciated. :slight_smile:

It’s probably the governor on the GPU being too slow to respond to workload changes. There are some plans to improve this. You’ll probably notice that after the initial stutter; they’re gone as the GPU stays at a higher frequency for a while. You could try running the GPU at a higher frequency (you would want to set this on boot in rc.local) with:

echo 744 | sudo tee /sys/class/mpgpu/cur_freq

That’s coming.

Hopefully we can improve Kodi’s NFS mounting performance instead.

Unless you added a gigabit adapter to the Vero, you’re only getting 100Mbit, which is of course 10x slower. One thing to check is your Ethernet switch…100Mbit can be handled poorly even though your switch is fine with gigabit. And, some switches have issues with mixed speed source and destination ports. These things could lead to slower than even 100Mbit speeds.

Even with that though, you’re getting slow gigabit to gigabit transfer rates. A 50GB file transfers at 110MB/sec for me on gigabit ethernet (share to local Windows 7 PC).

Well this sustained data of 60 - 70 MB/Sec is downloading a file from my 5 year old Synology 413J. So I think the Synology might be here the limiting factor.