First experiance with Vero 4K


I just received my Vero 4K hoping it will solve all my problems with RP3.

Added library over SMB share and played two movies that have DTS HD-MA.
I tried the stock version and No HD-MA on receiver. Went to settings and enabled passthrough, still no HD-MA changed from PCM to HDMI still no passthrough.

Enabled DTS HD then the sound is muted when passthorugh is enabled.

Then updated to the latest version and rebooted.
Once booted the system crashed and had to make a hard reboot via power.

When playing the DTS HD-MA file again it says Multi-CH PCM in the display.
when the file is playing and i go to sound settings via popup screen and disable passthrough the display still shows the same on the reciever: Multi-CH PCM

went to settings in system and changed:

Output Configuration: Best matched
Resample quality: High
then a high crackeing sound began in the rear speakers.

a DTS movie works but not DTS HD-MA for now.
Switched on and off in the popup meny for passthrough and Boom! DTS HA-MA works :slight_smile:
Same on another move.

I have to get into the popupmenu and disable then enable Passthrough then HD-MA works!
Is this a kind of bug or do i have wrong setting somewhere? lol

Well i at least got it to work.

thanks in advance.

EDIT001: when pauseing the movie for some seconds the sound is dissapearing aswell,
enable and disable passthrough fast makes the unit it hang itself and you have to make a power reboot.

EDIT002: Crackeing:
Workaround: I disabled the GUI sound since the system is getting crackeing sound when going from the HD-MA sound to menu and the gui sound and now works better.

EDIT003: When trying to enable the DTS HD-MA sound as per solution above via popup meny the system have now hanged two times in w row, event if i wait 10 seconds for each action.


First thing – is the device up to date?
Also – is the device plugged directly in to the wall?


Hello Sam,

yes it´s the latest update and wired rj45.
I am going to tri the stock HDMI and see if there is any differences.

Biggest problem now is that the DTS HD-MA does not kick in and its no sound at all. or it crashes, if not crashes then stopping video and play and resume seems to work right now.

Crashing etc doesn’t sound right. My recommendation is to install fresh from Download - OSMC (if you have a micro SD card spare).

If you have further issues, enable debug logging and post it. Also take a photo of audio settings


About the cracking: I’ve had the same problem when stopping a DTS-HD or Atmos video: cracking sound with every UI sound, but also very loud static noise as well. First time this happened, I litteraly jumped off my seat.

This disappeared completely after changing one setting in the System settings audio menu.
Output configuration
I’ll have to check when I’m back at home, but I think I have set this to “Best match” instead of “Optimized” (the default value).

Hello Sam,
I reinstalled and changed to the stock HDMI and things is now working better.

Same problem with the DTS HD-MA though, sometimes there is no sound and sometimes there is only multi channel. Enable and disable passthrough and stopping video and restart video is the workaround i found here, works 80% of the time.

Have you any experiance of this?

Yeah i have 500Wrms sub and i lol what a cracking sound… I disabled the GUi sound just to be sure.
Never had the problem after that :slight_smile: