Fixed IP Problems

When I try to put in a fixed IP then the ATV1 stops connecting to the Ethernet.
Only had luck with DHCP

It’s so I don’t have to keep reconfiguring web remote on iPad or Web Browser etc.

Are you certain that you are not trying to set an IP that is already being used by another device? Are you certain that the IP you are trying to set is appropriately within your subnet?

  1. I’m pretty sure I chose an IP quite different.
    I put a 1 where there is usually a 0.

I shall do an idiot check

  1. “Are you certain that the IP you are trying to set is appropriately within your subnet?”
    I am not quite sure what that means?

Please explain what IP DHCP has handed the device and the IP that you wish to now set for it.

Gateway 192:168:0:1
Most DHCP devices 192:168:0:2 to 192:168:10

At the moment it DHCP’s to 192:168:0:2

If I change it to manual with the same IP and…
It is now working :slight_smile:

Ohhhh Dear. What a Donut. Should have tried again before posting. Not sure why it gave me hassle before.
Thanks for helping anyway.


If your set up is typical then you’ll have a gateway at and a subnet mask of

The subnet mask defines which part of an IP address relates to the network and which part relates to the host.

So, defines that 192.168.0 is the network address and hosts on that network can take addresses from to

From your second post I assume you tried an address of 192.168.1.something

As this address isn’t in the range recognised as being on your network, you device wouldn’t be able to connect to the gateway.

One thing to be wary of is if your router is handing out IP addresses using DHCP, then if another device gets given (if it is powered on before your ATV) then this will cause a conflict. Most routers have some form of IP reservation where you can set the IP that will be allocated to a device based on it’s MAC address. Login into your router at and have a look at the settings available. Probably safer to do the address allocation this way.

1 Like

I think that was a typo where op simply omitted a zero.

Absolutely correct. I used 192:168:1:3 thinking it would be well out of reach. Too out of reach…

Just had an IP conflict before typing this when iPhone stole Macbooks sleeping IP.

Thanks for clearing that up. So ATV can be 192:168:0:50 something and never cross another device in my home.

The first three octets must match. That would be the subnet. You can only change the last octet to be some number 2-255.

Managed to keep my knowledge of networking to an absolute minimum :laughing:

You keep on writing the IP address with colons rather than full stops

192:168:0:1 rather than

As far as I know that is not possible?

That’s just my mistake posing on here. I did it with “.” on the ATV1 :smirk: