FLAC won't play on RPi3 w/hifiberry dac+light

So I’m a new owner of a raspberry pi 3 with a hifiberry dac+light installed running OSMC and retrosmc. I’ve been able to get it all setup relatively painlessly. My videos play fine, I can get into RetroPie and play my emulators just fine. The only thing I’m having trouble with is playing my audio library, specifically FLAC files. I don’t know what is wrong and I’ve had a hard time finding help for this specific problem so I thought I’d create this thread in the hopes someone can point me in the right direction.

So I found the thread about how to make a support thread so I enabled debug mode, rebooted and tried to play some music. The file I tried to play is called 01 - Now You Know.flac incase anyone wants to search for the relevant lines in the logs, which you can find here. One thing I forgot to mention is that I have no problems playing these files if I convert them to mp3. Also, they are all stored on an external USB HDD attached to the pi, but has its own power source.

Here is what MediaInfo has to say about the FLAC.

Thanks in advance to everyone! Let me know if I can provide more info.


There is a line in the log that states kodi couldn’t open the file.

Do the .flac files have the corect permissions to be readable by the osmc user?

I tried looking at the permissions but nothing seemed out of the ordinary.


EDIT: Ok so I dug further and went into a directory with .flac files and did another ls -la command.


Now it looks like you might be right. I’m going to see if I can modify the permissions then report back. Thanks for the tip.

EDIT 2: It was the permissions, thanks for helping out!

You’re welcome, glad you got it working.