FLACs tend to sound... Chipmunky

First, Got this Vero today… It’s mindblowingly good. The attention to detail is amazing, congratulations to the team.

So i got myself a FLAC test file with a bitrate of 833kbps, stored it on my NAS, and added it to my Vero 4K’s library.

All other test files (including 4k videos, h.265, etc.) played fine without any lag or problem, but the FLAC file had its pitch really up and it is very distorted.

It’s hooked up to a stereo setup… on the HDMI IN port of an Xbox One. (Still testing!)

This never happened on my RPi3.

Any idea where i should start looking?


Okay, now i’m confused. MP3 does the same thing.


Logs: http://paste.osmc.io/arozisocey

(It’s a blank page. Something i’m doing wrong?)

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

  • Can you post debug logs?
  • Can you post me a link to an afflicted MP3 or FLAC? (send me a PM)

With this information, we should be able to put it right.

Cheers

Sam

I had the same on my Vero 4k and suspect it has to do with the flow handling of my Switch.
I had to add:

    <cache>
       <buffermode>1</buffermode> <!-- Default is 1 -->
       <memorysize>90000000</memorysize> <!-- Default is 20971520 bytes or 20 MB -->
       <readfactor>4.0</readfactor> <!-- Default is 1.0 -->
    </cache>

to my advancedsettings configuration.

Note that my vero is hooked up using fast ethernet (No WiFi).

1 Like

I added those lines to the advancedconfig.xml on the .kodi/userdata, i assume that’s the one you meant, right?

The issue still persists. This is indeed very strange!

Weird is this happens out of the box… oh well. Fingers crossed! Thanks for your help, @Smurphy.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Can you try connect it to the TV directly?
As an aside: @DBMandrake doesn’t recommend Xbox One’s HDMI-in. Doesn’t handle refresh rate adjustment correctly.

Sam

1 Like

You restarted the kodi app ???
it won’t load the advanced settings without a restart.

I did, and that tweak also mean my Vero couldn’t access my NAS, connection was dropped. It’s a Western Digital My Cloud 2TB via SMB.

Connected directly to the TV the audio plays fine, all formats…

I’m completely :open_mouth: right now! I’ve had lots of stuff connected to the HDMI IN of this Xbox : STB’s, Chromecasts and the aforementioned RPi3, without any problems!

I’ll keep it connected directly to the TV then.

Thank you very much, to you both @sam_nazarko and @Smurphy!

@TFrutuoso, what is your GUI resolution and refresh rate set to? If you have the resolution higher than 1080p, that could be causing the problem.

Apparently Xbox One doesn’t do anything other than 50Hz or 60Hz. That would explain the problem.

Chromecasts don’t support refresh rate switching. So you wouldn’t see a problem there.

But why would the HDMI port capabilities affect flac playback? Make it shoppy?
Just trying to understand here… :}

I think he’s playing video with FLAC rather than just audio.

FLAC has to be decoded to PCM first. If we switch to 24Hz but Xbox can only do 50 or 60, it will not sound correct.

Ok. that - I can understand :slight_smile: Thx.

Beware with setting the memorysize to numbers looking like yours. I’ve found out that Kodi 17 likes to write the cache to disk (!) when the number isn’t derived from 1kb = 1024 bytes.

A proper value would be: 94371840 which equals to exactly 90 megabytes.

I took the numbers from the Kodi Wiki actually.

Yes, so did I. That’s why it took me a while to figure out what the cause of writing the cache to the internal storage was.

Watch your .kodi/temp folder while playing a video. I’d be surprised if you don’t have a growing file there.

Should not be related to the number being derived from 1024,

  <memorysize>0</memorysize>  <!-- number of bytes used for buffering streams in memory
   When set to 0 the cache will be written to disk instead of RAM -->

http://kodi.wiki/view/HOW-TO:Modify_the_video_cache