Flashing/glitching 60fps video on Raspberry Pi 4B

I’m experiencing very brief flashes of white noise looking stripes across the bottom of the screen on any 60fps video.

I first noticed this with the youtube add on. But I downloaded some 1080p 60 videos to test and I’m also seeing the problem there.

I’ve searched the forums but don’t seem to find others with a similar issue.
Any help would be really appreciated!

Here is a log reproducing the issue… hoping it can provide some clues!


Did you tried the other HDMI port on the Pi?
Did you tried another HDMI cable?

Does this occur with all videos or just some?

The issue does sound HDMI related as @fzinken says and I’d also be interested in the length of your HDMI cable.


It occurs with all 60fps video as far as i can tell.
I’ve tried another HDMI cable and the problem persists. Both cables about 1.5m.

Here is a video of the screen to demonstrate more clearly:

Edit: Just to clarify: non-60fps videos play back perfectly.

I can see the video flash.

We will update kernel to 5.15 shortly on Raspberry Pi, as well as video firmware. This might solve the issue. However – we’ve a lot of users and haven’t received such a report recently of such an issue. But there’s been a lot of HVS and clock improvements for Pi 4 in newer kernel and firmware updates and this could help.

I’ve also asked @popcornmix, Raspberry Pi engineer if he’s seen something like this with our current video stack with a link to this post.

I’ll let you know when I’ve made this change available for testing.



Thanks a lot! Will try the new build as soon as it’s available.

Just to let you know that the Pi 5.15 kernel will be available in the January 2023 update which will be released imminently.

I hope this resolves your issue.


Sorry to break your talk. Do you know why I can’t get subtitles on Enigma2 recordings from Movistar+ with osmc and Raspberry Pi ?

No – but if you want this investigated, you should start your own thread.

I’ve already started my own thread. Sorry to reply in the lost_highway thread. My thread is ‘engnima2 subtitles’ but I thought you would have the answer to my question because you are the osmc designer and you can to implement this feature in osmc your masterpiece.

I don’t have any access to an Engima 2 system.

I read every forum post here however. If I had a solution I would have provided it.


I have the exact same issue, I thought I was imagining it haha. Fingers crossed for the mid Jan update :slight_smile:

@lost_highway did you ever manage to solve this? It’s still happening for me, same specs I think pi4 et al

Maybe I should try swapping HDMI cables.