Flickr Filesystem on OSMC

Hi All,

I would like to have Flickrfs installed on OSMC. Probably this is a bit off topic, but the problem is that I want to understand the compatibility of OSMC with Raspbian. Let me explain.

I am following this guide for Raspbian:
http://andersonvom.tk/2014/03/02/flickrfs-on-raspberry-pi.html

it does not work on OSMC because the following line is missing in /etc/apt/source.list:
deb http://archive.raspbian.org/raspbian wheezy main contrib non-free

if I give:
sudo apt-get update
sudo apt-get install flickrfs

the package is found and some dependencies are installed like:
python-central python-fuse

Now my question is: can I do this with OSMC? Is there any problem adding Raspbian repo to OSMC?

Basically what I want is the following:

  1. keep in sync my Flickr account with my OSMC box
  2. see Flickr images using Flickr add on (but it is a little bit slow when it opens a gallery)
  3. use another addon to slideshow my photo stored on local (to be more fast)
  4. Whenever I come back from a vacation I quickly download SD Card on my OSMC box and it automatically sync with my Flickr account. Probably I can manage this directly from Kodi.

What do you think about this?

What dependencies are missing?

Please post the FULL output of the command

sudo apt-get update && sudo apt-get install flickrfs

The installation worked fine. My problem was that I didn’t launched the command because I was afraid some incompatibility could occurs between Raspbian and OSMC repo. At the end I did it and the installation went ok. So I assume that it is possible to add the Raspbian repository to the OSMC source.list file.
This was my concern.

Now I installed also lynx and completed the guide directions:
http://andersonvom.tk/2014/03/02/flickrfs-on-raspberry-pi.html
https://sites.google.com/site/manishrjain/flickrfs

but launching the command:
flickrfs

I get:
Authorizing with flickr…
Can’t retrieve token from browser:/usr/bin/lynx:
If you’re behind a proxy server, first set http_proxy environment variable.
Please close all your browser windows, and try again

I set my API key and secret but it didn’t work. See log files below.
I know this is a flickrfs issue and probably this is not the right place to further discuss this stuff. But if someone had experience with this problem please I would appreciate the help.

File “/usr/share/pyshared/flickrfs/flickrapi.py”, line 272, in handler
f = urllib2.urlopen(req)
File “/usr/lib/python2.7/urllib2.py”, line 154, in urlopen
return opener.open(url, data, timeout)
File “/usr/lib/python2.7/urllib2.py”, line 437, in open
response = meth(req, response)
File “/usr/lib/python2.7/urllib2.py”, line 550, in http_response
‘http’, request, response, code, msg, hdrs)
File “/usr/lib/python2.7/urllib2.py”, line 475, in error
return self._call_chain(*args)
File “/usr/lib/python2.7/urllib2.py”, line 409, in _call_chain
result = func(*args)
File “/usr/lib/python2.7/urllib2.py”, line 558, in http_error_default
raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
HTTPError: HTTP Error 403: Forbidden

12/13/16 17:37:07 ERROR Can’t retrieve token from browser:/usr/bin/lynx:
12/13/16 17:37:07 ERROR Got key error. Exiting…

I suspect that flickrfs is no longer mantained. Anyone else is able to sync a linux folder with Flickr on OSMC?

Where in those instructions did it say to edit the /etc/apt/sources.list file? I can’t see it.

Can you list out exactly what commands you’ve issued so far. If you were blindly following those commands you would have added the pi user to the fuse group. OSMC does not have a pi user so that might be where the problem is.

Yes, it does look like it’s no longer maintained. The last release of this looks to be almost 10 years old (Although this appears to have worked in 2014).

Reading some of the bug tickets on SourceForge (Flickr Filesystem / Bugs / #16 Flickr HTTPs authentication only) it looks like this no longer works since June 2014.

I think you are wasting your time with this.

If you have not already done so, I’d take out the Raspbian repo from your sources.list. It might not cause any problem being there but I’d remove it to be on the safe side.

I did it by myself. I know a bit about debian. The tutorial was about Raspbian this is the reason it does not appear into the tutorial. For OSMC it is required. flickrfs is no longer supported, you’re right I am wasting my time. I also checked others tools but I was unable to have them work properly.

To be honest have the possibility to manage photo directly from OSMC would have been great but I think it’s not easy. However, the thread was about the Raspbian/OSMC cmpatibility.

I removed the line as suggested. If someone else on this forum have OSMC in sync with Flickr in some way I would appreciate any help. Otherwise I think this thread can be considered closed.

The OSMC standard sources include most standard debian packages, you should not add raspbian repos.

I thought the same but after a little investigation I could find the flickrfs package in the Raspbian repo but not in the Debian repo.

Still it’s sorted now as the package doesn’t work any longer anyhow.

Ok thx. I saw there are other software out there. But all of them requires an authorization step that need the use of browser that on OSMC must be lynx and navigate with it it’s not easy. I’ll continue to investigate on this and if I didn’t find anything I’ll write a software by myself just to keep in sync my local folders with Flickr.

I am trying this tool:

it seems work properly. For the moment I did:

git clone GitHub - faisalraja/flickrsmartsync: Sync your photos to flickr
cd flickrsmartsync
python setup.py install --user

to be honest I didn’t use the --user and I installed it as root and for this reason I have to use always sudo. So I think with --user you install with osmc user.

then launch:
flickrsmartsync

it shows an url and you cut & paste in a browser to authorize the app, then

cd
flickrsmartsync --download .

All the Flickr photos are correctly downloaded. Now I’ll try to do all the scenarios reported above. As soon as I finish I’ll post a tutorial on this forum.

Forgot to mention,
You need an API key (it’s not a good idea use API author to access your private photo).
Then set them in remote.py file before launching the command:
python setup.py install --user

Also the command:
flickrsmartsync --sync-path .

works fine to keep a linux folder in sync with Flickr account.
–sync-path use a different service of --download so you need to authorize it using the URL method reported above.

I think probably I have found what I needed. With a cron task it could be possible to keep the folder in sync with remote changes or just do it manually when necessary. I do not update Flickr too often.

Hi All,
I tested the procedure above on a linux machine without graphical interface and it worked properly. The linux box didn’t have a browser. On OSMC I had to hack the python code of the flickrsmartsync tool because it activates a browser instead of show the link to cut&paste on my browser on my PC. This is required because the app must be validate by Flickr before you can use it.

To hack the code I simply edited the remote.py file and printed the url with a return because webbrowser.get() command is called. It seems that this Python API call the system browser and it seems OSMC has a browser like lynx installed by default. Reading some website I understand the name of this browser is ocelot.

Could someone tell me if this is the name? Where I can found the executable file and how I can configure python so that the webbrowser.get() API do not call the OSMC internal browser.

I would like to solve the issue without hack any code so that anyone can replicate my installation steps.
Thanks in advance for help.